summaryrefslogtreecommitdiffstats
path: root/network/aMule/aMule.SlackBuild
blob: 537977466719598b48e58e5375252809c57d37f6 (plain)
#!/bin/sh

# Slackware build script for aMule
# Written by Iskar Enev (iskar.enev@gmail.com)

# Modified by the SlackBuilds.org project

PRGNAM=aMule
VERSION=2.1.3
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
fi

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT

cd $TMP || exit 1
rm -rf $PRGNAM-$VERSION
tar -xjvf $CWD/$PRGNAM-$VERSION.tar.bz2 || exit 1
cd $PRGNAM-$VERSION || exit 1

chown -R root:root .
chmod -R u+w,go+r-w,a-s .

# This is an optional patch to build aMule 2.1.3 against new wxWidgets 2.8.0. 
# It fixes the "crash on search tab close" which is an wxWidgets bug, 
# not an aMule bug, and it's fixed on the 2.8.0 version.
# Patch provided by arekm <arekm@pld-linux.org> and approved by the
# aMule mainainer (see website)
#cat $CWD/aMule-wx2.80.patch | patch -p1 || exit 1

CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --sysconfdir=/etc \
  --localstatedir=/var \
  --mandir=/usr/man \
  --with-wx-config=/usr/bin/wx-config \
  || exit 1
  
make || exit 1
make install DESTDIR=$PKG || exit 1

( cd $PKG
  find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
  find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
)

( cd $PKG/usr/man
  find . -type f -exec gzip -9 {} \;
  for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
)

# Let's fix the icon path in the menu entry so that the icon will show
# up when using KDE
sed -i 's@Icon=amule.xpm@Icon=/usr/share/pixmaps/amule.xpm@g' \
  $PKG/usr/share/applications/amule.desktop || exit 1

# All of the needed docs are already installed; we'll just move them to the
# correct location 
cp -a $PKG/usr/share/doc $PKG/usr
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz