summaryrefslogtreecommitdiffstats
path: root/games/xspacewarp/xspacewarp.SlackBuild
blob: 8cc8d3cbe6db636af5b5d1881481eaf188ad45ac (plain)
#!/bin/bash

# Slackware build script for xspacewarp

# Written by Niels Horn <email removed>.
# man page by Luis Henrique <email removed>.
# Formerly maintained by Ryan P.C. McQuen.
# Now maintained by B. Watson <urchlay@slackware.uk>.

# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.

# 20211012 bkw: BUILD=3
# - relicense as WTFPL with permissions from Ryan (who was the one
#   who originally added the license).
# - new-style icon.
# - use copy of app defaults file shipped with the source, instead
#   of including our own. they were identical except for one extra
#   blank line.
# - fix man page typos.
# - make the window close button work.

# 20170309 bkw:
# - take over maintenance
# - fix download & homepage URLs
# - i486 => i586
# - minor tweaks

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=xspacewarp
VERSION=${VERSION:-1.2b}
BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

SRCVER=$(echo $VERSION | cut -b -3)

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$SRCVER
tar xvf $CWD/$PRGNAM-$SRCVER.tar.gz
cd $PRGNAM-$SRCVER
chown -R root:root .
find -L .  -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
        \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+

# Apply patch to version 1.2b (adapt for modern gcc compiler)
patch -p1 < $CWD/version12b.patch

# Patch by B. Watson: make the window close button work. This took
# more effort than I wanted it to... and I had to look at the source
# to xbiff to see how this gibberish works.
patch -p1 < $CWD/winclose.diff

xmkmf
make Makefile
make CDEBUGFLAGS="$SLKCFLAGS -fno-strength-reduce -fno-strict-aliasing" $PRGNAM

strip $PRGNAM
make install BINDIR=/usr/games DESTDIR=$PKG

mkdir -p $PKG/usr/share/applications \
         $PKG/usr/share/pixmaps \
         $PKG/usr/share/icons/hicolor/32x32/apps
cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
cat $CWD/$PRGNAM.png > $PKG/usr/share/icons/hicolor/32x32/apps/$PRGNAM.png
ln -s ../icons/hicolor/32x32/apps/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png

mkdir -p $PKG/etc/X11/app-defaults
cat XSpacewarp.app_def > $PKG/etc/X11/app-defaults/XSpacewarp.new

mkdir -p $PKG/usr/man/man6
gzip -9c <$CWD/xspacewarp.man > $PKG/usr/man/man6/xspacewarp.6.gz

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a CHANGES $PKG/usr/doc/$PRGNAM-$VERSION/
cat $CWD/xspacewarp-1.2.README > $PKG/usr/doc/$PRGNAM-$VERSION/README
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE