summaryrefslogtreecommitdiffstats
path: root/games/maelstrom/maelstrom.SlackBuild
blob: 1e1b3ecde64275e16f9fb6057fc5e17d8b164cbe (plain)
#!/bin/sh

# Slackware build script for maelstrom

# Written by B. Watson (yalhcru@gmail.com)

# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.

# Note to 64-bit users: Maelstrom-netd and the -server option to Maelstrom
# do not work correctly. I haven't investigated why. You can still play
# networked games in non-server mode (see man page). Users of 32-bit
# Slackware are not affected by this.

PRGNAM=maelstrom
VERSION=${VERSION:-3.0.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

SRCNAM=Maelstrom

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i486 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
chmod -R a-s,u+w,go+r-w .

# Fix 64-bit compile issue (not needed on 32-bit, but does no harm)
patch -p1 < $CWD/compile_fix.diff

# Install game data in /usr/share/games/Maelstrom, not /usr/games/Maelstrom
# (also make `make install' support DESTDIR properly!)
patch -p1 < $CWD/install_dirs.diff

CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --bindir=/usr/games \
  --build=$ARCH-slackware-linux

make
make install DESTDIR=$PKG
strip --strip-unneeded $PKG/usr/games/*

# CLI users would probably prefer to type 'maelstrom', not 'Maelstrom'
( cd $PKG/usr/games && ln -s $SRCNAM $PRGNAM )

install -m0755 -o root -g root $CWD/maelstrom_addon_package.pl $PKG/usr/games

mkdir -p $PKG/usr/share/applications
cp $CWD/$PRGNAM.desktop $PKG/usr/share/applications

mkdir -p $PKG/usr/share/pixmaps
( cd $PKG/usr/share/pixmaps ; ln -s ../games/$SRCNAM/icon.xpm $PRGNAM.xpm )

mkdir -p $PKG/usr/man/man6
gzip -9c $CWD/$SRCNAM.6 > $PKG/usr/man/man6/$SRCNAM.6.gz
( cd $PKG/usr/man/man6
  ln -s $SRCNAM.6.gz $PRGNAM.6.gz
  ln -s $SRCNAM.6.gz $SRCNAM-netd.6.gz )

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
make install_gamedocs target=$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
# Why does `make install' install this?
rm -f $PKG/usr/doc/$PRGNAM-$VERSION/Docs/Makefile

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}