summaryrefslogtreecommitdiffstats
path: root/games/d2x-rebirth/d2x-rebirth.SlackBuild
blob: 0cafd4fd74ce1d650c4a3662f1ee0aa35a84f96a (plain)
#!/bin/bash

# Slackware build script for d2x-rebirth

# Copyright 2012-2015 Andrew Strong, Blue Mountains Australia.
# Copyright 2017 Alan Ianson, Penticton, BC Canada.
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

# 20220321 bkw: Modified by SlackBuilds.org: fix 32-bit build.
# TODO: the executable needs to go in /usr/games, and the .desktop
# needs absolute paths to the icon and executable.

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=d2x-rebirth
SRCNAM=dxx-rebirth
VERSION=${VERSION:-20220130_7258b7f}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.xz
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
 -exec chmod 755 {} \+ -o \
 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
 -exec chmod 644 {} \+

# 20220321 bkw: I hate scons, and I hate people who use -Werror and
# don't give a sane way to disable it. I especially hate them if they
# write code that triggers warnings... 32-bit builds were failing
# because of this.
sed -i -e "s,'-W','-Wno-'," -e "s,'-Werror=','-Wno-error='," SConstruct

# 'sharepath' is for the game-content data files, they can
#  also perhaps more conveniently go in ~/.d2x-rebirth...
scons CXXFLAGS="$SLKCFLAGS" \
      prefix=/usr \
      sharepath=/usr/share/$PRGNAM \
      d2x=1

# DESTDIR does not work so we do it manually:
install -D -m 0755 build/$PRGNAM/$PRGNAM $PKG/usr/bin/$PRGNAM
install -D -m 0644 $PRGNAM/$PRGNAM.xpm $PKG/usr/share/pixmaps/$PRGNAM.xpm
install -D -m 0644 $PRGNAM/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop

find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

# d2x.ini is a handy list of commandline options...
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
  d2x-rebirth/{CHANGELOG.txt,RELEASE-NOTES.txt,d2x.ini} README.md COPYING* GPL* \
  $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE