summaryrefslogtreecommitdiffstats
path: root/development/xa/xa.SlackBuild
blob: 8929e7cb1005727422cdfb05a9a016307babfc9f (plain)
#!/bin/sh

# Slackware build script for xa

# Written by B. Watson (yalhcru@gmail.com)

# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.

# 20191129 bkw:
# - update for xa-2.3.10 and dxa-0.1.4
# - remove the patches for dxa, 0.1.4 has all the fixes applied
# - switch to naptime URLs since upstream breaks download links
#   every time a new release comes out

# 20170711 bkw:
# - update for xa-2.3.8
# - REALLY remove unused *.txt.1 copies of the patches (wtf?)

# 20150322 bkw:
# - update for xa-2.3.7
# - remove unused *.txt.1 copies of the patches

# 20141030 bkw: take the tiny little patches out of DOWNLOAD= since
# they were included in the script tarball all along.

PRGNAM=xa
VERSION=${VERSION:-2.3.11}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

# dxa is a separate distribution with its own version number
DXAVER=0.1.4

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .

# tarball permissions are worse than usual.
find . -type d -exec chmod 755 {} \; -o -type f -exec chmod 644 {} \;

sed -i "s,-O2,$SLKCFLAGS," Makefile

# Note: non-standard use of DESTDIR
make DESTDIR=/usr
make install DESTDIR=$PKG/usr MANDIR=$PKG/usr/man/man1
strip $PKG/usr/bin/*

# man pages are installed +x, ugh
chmod -x $PKG/usr/man/man?/*.?
gzip -9 $PKG/usr/man/man?/*.?

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README* COPYING ChangeLog TODO doc/* examples tests mkrom.sh \
  $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

# now build dxa
tar xvf $CWD/dxa-$DXAVER.tar.gz
cd dxa-$DXAVER

# Can't see a disadvantage to enabling the --long-options
sed -i "s,-O6,$SLKCFLAGS -DLONG_OPTIONS," Makefile

make
install -s -m0755 dxa $PKG/usr/bin
gzip -9c < dxa.1 > $PKG/usr/man/man1/dxa.1.gz

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}