summaryrefslogtreecommitdiffstats
path: root/development/processing/processing.SlackBuild
blob: 14e71a90d69b659f098e981ac503d4b2e4515c97 (plain)
#!/bin/sh

# Slackware build script for Processing
# Written by Diogo Leal (diogo@diogoleal.com)

PRGNAM=processing
VERSION=${VERSION:-1.5.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i486 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

set -e

rm -rf $PKG

mkdir -p $PKG/opt $OUTPUT
tar xvf $CWD/$PRGNAM-$VERSION-linux.tgz -C $PKG/opt
mv $PKG/opt/$PRGNAM-$VERSION $PKG/opt/$PRGNAM

mkdir -p $PKG/usr/share/{applications,pixmaps}
cp $CWD/processing.desktop $PKG/usr/share/applications
cp $CWD/processing.png $PKG/usr/share/pixmaps

chown -R root:root $PKG
find $PKG \
 \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
 -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
 -exec chmod 644 {} \;

find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}