summaryrefslogtreecommitdiffstats
path: root/development/dart-sdk/dart-sdk.SlackBuild
blob: 925bc0e0cae5a38394d3abb8c3bdf5f5caf1ef8e (plain)
#!/bin/sh

# Slackware build script for <dart-sdk>

# Copyright 2016-2019 Zhu Qun-Ying
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

PRGNAM=dart-sdk
VERSION=${VERSION:-2.7.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

echo "arch $ARCH"
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" == "x86_64" ]; then
    PKG_PLATFORM="x64"
elif [ "$ARCH" == "i586" ]; then
    PKG_PLATFORM="ia32"
elif [ "$ARCH" == "arm" ]; then
    PKG_PLATFORM="arm"
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP

mkdir -p $PKG/opt
cd $PKG/opt

unzip $CWD/dartsdk-linux-$PKG_PLATFORM-release.zip
unzip $CWD/dartdocs-gen-api.zip

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp $CWD/$PRGNAM.SlackBuild  $PKG/usr/doc/$PRGNAM-$VERSION
mv gen-dartdocs $PKG/usr/doc/$PRGNAM-$VERSION/doc

mkdir -p $PKG/etc/profile.d
cp $CWD/dart-sdk.*sh.new  $PKG/etc/profile.d

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

chmod +x $PKG/opt/dart-sdk/bin/resources
chmod +x $PKG/opt/dart-sdk/bin/resources/dartdoc/

cd $PKG
chmod +rx opt/dart-sdk opt/dart-sdk/bin opt/dart-sdk/bin/snapshots/
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}