summaryrefslogtreecommitdiffstats
path: root/development/argouml/argouml.SlackBuild
blob: 73a6dea467ff5d4f91ea5470078e2074f4c97240 (plain)
#!/bin/sh

# Copyright 2009  Robert Allen - slacker@slaphappygeeks.com
# All rights reserved including Creator Endowed Unalienable Rights.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

PRGNAM=argouml
VERSION=${VERSION:-0.28}
ARCH=i486
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

set -e

rm -rf $PKG
mkdir -p $PKG/usr/lib $OUTPUT
tar xvf $CWD/ArgoUML-${VERSION}.tar.gz -C $PKG/usr/lib

# Add a convenience symlink to keep path simple
( cd $PKG/usr/lib ; ln -s $PRGNAM-$VERSION $PRGNAM )

# Symlink the executable to /usr/bin ; no need for a wrapper, as upstream
# handles that quite well in their launcher script
mkdir -p $PKG/usr/bin
( cd $PKG/usr/bin ; ln -s /usr/lib/$PRGNAM/argouml.sh argouml )

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
( cd $PKG/usr/doc/$PRGNAM-$VERSION 
  ln -s ../../lib/$PRGNAM-$VERSION/README.txt . 
)

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
chown -R root:root .
/sbin/makepkg -c n -l y $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz