summaryrefslogtreecommitdiffstats
path: root/desktop/crystalcursors/crystalcursors.SlackBuild
blob: aa9dc3df0e4c70d8ab29d6953767ec6e10819522 (plain)
#!/bin/sh

# Slackware build script for crystalcursors

# Written in 2007 by Yalla-One <yallaone@gmail.com>
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

PRGNAM=crystalcursors
VERSION=1.1.1
ARCH=noarch
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

rm -rf $PKG $TMP/tmp-$PRGNAM
mkdir -p $TMP $PKG $OUTPUT $PKG/usr/share/icons || exit 1
cd $TMP
tar xvf $CWD/${PRGNAM}_${VERSION}.orig.tar.gz || exit 1
mv Crystalcursors tmp-$PRGNAM
cd tmp-${PRGNAM}
chown -R root.root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
 -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

make || exit 1
make install PREFIX=$PKG/usr/share/icons || exit 1

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a CHANGELOG CREDITS LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION/
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/${PRGNAM}.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc || exit 1

# We're not going to have a package installation change any system-wide
# defaults, so we'll first move the index.theme file to the documentation
# directory so that it's easy to find, and then wipe the $ICONS/default dir.
mv $PKG/usr/share/icons/default/index.theme \
  $PKG/usr/doc/$PRGNAM-$VERSION/index.theme.default
rmdir $PKG/usr/share/icons/default

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}