summaryrefslogtreecommitdiffstats
path: root/accessibility/xdotool/xdotool.SlackBuild
blob: 75e773b92dd006b4dfc05eed8946f2b2639af633 (plain)
#!/bin/bash

# Slackware build script for xdotool

# Written by B. Watson (urchlay@slackware.uk)

# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.

# 20230711 bkw: updated for v3.20211022.1.
# 20220610 bkw: updated for v3.20210903.1.

# 20200329 bkw:
# - BUILD=3
# - Stop including references to the build and $PKG dirs in the binary. This
#   was a potential security risk. Thanks to Leonardo Citrolo for reporting
#   this (along with a solution).
# - Actually install the binary stripped.

# 20191219 bkw:
# - BUILD=2
# - install API (doxygen) docs.

# 20170618 bkw:
# - stop running ldconfig during 'make install'. this is really just me being
#   nitpicky, but build scripts should never affect anything outside of $TMP.

# 20170301 bkw:
# - get rid of support for v$VERSION.tar.gz
# - use correct WTFPL link
# - rearrange changelog so newer entries at the top

# 20161010 bkw:
# - v3.20160805.1, BUILD=1
# - install doc/examples/*.sh without execute bits.

# 20160831 bkw:
# - bump BUILD
# - strip shared lib, not just the binary.
# - change the header permissions in $PKG, not /usr/include!
#   thanks to vonbiber for spotting these.

# 20151126 bkw:
# - fix xdo.h permissions

# 20151028 bkw:
# - updated for xdotool 3.20150503.1.

# 20120411 bkw:
# - updated for xdotool 2.20110530.1.
# - install CHANGELIST in doc dir
# - make & install HTML doc instead of raw POD doc
# - fix permissions in examples/

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=xdotool
VERSION=${VERSION:-3.20211022.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L .  -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
        \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+

# 20200329 bkw: make this section a bit more readable I hope.
# The LDCONFIG=true is counter-intuitive: it means "run the 'true'
# command instead of the 'ldconfig' command". In other words, do
# NOT run ldconfig (opposite of what it seems to mean in English).
COMMON="WITHOUT_RPATH_FIX=1 LDCONFIG=true"
LIBDIR=/usr/lib$LIBDIRSUFFIX

mkdir -p $PKG/$LIBDIR

make \
  WARNFLAGS="$SLKCFLAGS" \
  PREFIX=/usr \
  INSTALLLIB=$LIBDIR \
  $COMMON

make install \
  PREFIX=$PKG/usr \
  INSTALLLIB=$PKG/$LIBDIR \
  $COMMON

# 20200329 bkw: strip binary *after* installing, since 'make install' is
# relinking it.
strip $PKG/usr/bin/$PRGNAM $PKG/usr/lib$LIBDIRSUFFIX/libxdo.so.?

make docs $PRGNAM.html

gzip -9 $PKG/usr/man/man1/$PRGNAM.1

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
chmod 0644 examples/*.sh $PKG/usr/include/*.h
cp -a CHANGELIST README* COPYRIGHT examples $PRGNAM.html docs/html \
      $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE