summaryrefslogtreecommitdiffstats
path: root/academic/xcircuit/xcircuit.SlackBuild
blob: 6aab5bca42030e5ee7a561cdda638514547adde9 (plain)
#!/bin/sh

# Slackware build script for grace
# Written by B. Jogai <jogaib {at} comcast [dot] net>

# Set initial variables:

PRGNAM=xcircuit
VERSION=3.7.6
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-"_SBo"}

CWD=$(pwd)
TMP=${TMP:-"/tmp/SBo"}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-"/tmp"}

if [ "$ARCH" = "i486" ]; then
    SLKCFLAGS="-O2 -march=i486 -mtune=i686"
    LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
    SLKCFLAGS="-O2 -march=i686 -mtune=i686"
    LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
    SLKCFLAGS="-O2 -fPIC"
    LIBDIRSUFFIX="64"
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION $PRGNAM
tar xvf $CWD/$PRGNAM-$VERSION.tgz
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .

chown -R root:root .
chmod -R u+w,go+r-w,a-s .

CFLAGS="$SLKCFLAGS" \
    ./configure \
    --prefix=/usr \
    --bindir=/usr/bin \
    --libdir=/usr/lib${LIBDIRSUFFIX} \
    --mandir=/usr/man \
    --with-x \
    --with-ngspice \
    --with-tcl=/usr/lib${LIBDIRSUFFIX} \
    --build=$ARCH-slackware-linux \

make
make DESTDIR=$PKG install

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/examples

cp -a CHANGES README* TODO VERSION examples/ \
    $PKG/usr/doc/$PRGNAM-$VERSION

find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;

cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true


# Add desktop menu entries
mkdir -p $PKG/usr/share/{applications,pixmaps}
cat $CWD/xcircuit.png > $PKG/usr/share/pixmaps/xcircuit.png
cat $CWD/xcircuit.desktop > $PKG/usr/share/applications/xcircuit.desktop

# Copy the man pages from the lib to the man directory.
# Don't move it in case the program needs it there for some reason.
rm -rf $PKG/usr/man
mkdir -p $PKG/usr/man/man1
rm -f $PKG/usr/man/man1/*.1
cp $PKG/usr/lib$LIBDIRSUFFIX/$PRGNAM-3.7/man/*.1 $PKG/usr/man/man1

# Compress the man pages if they exist
if [ -d $PKG/usr/man ]; then
    ( cd $PKG/usr/man
	find . -type f -exec gzip -9 {} \;
	for i in $(find . -type l) ; do
	    ln -s $(readlink $i).gz $i.gz
	    rm $i
	done
	) 
fi

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG

/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}