summaryrefslogtreecommitdiffstats
path: root/academic/octave/octave.SlackBuild
blob: b0424312d4be8b536a3ef518d762d426f6dbe9cf (plain)
#!/bin/sh

# Slackware build script for octave

# Copyright 2012-2019 Kyle Guinn <elyk03@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

PRGNAM=octave
VERSION=${VERSION:-5.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$(uname -m)" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$(uname -m) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM-$VERSION
OUTPUT=${OUTPUT:-/tmp}

DOCS="AUTHORS BUGS CITATION COPYING ChangeLog INSTALL* NEWS README"

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

# Use GraphicsMagick by default.  Fall back on ImageMagick from the full
# Slackware install if it's not present.  Requires a patch for this bug:
# https://savannah.gnu.org/bugs/?49653
#
# GraphicsMagick is default due to the fact that the Octave devs mainly test
# with that, and went several releases before noticing ImageMagick was broken.
# If ImageMagick doesn't work, install GraphicsMagick, or set MAGICK="".
MAGICK=${MAGICK-GraphicsMagick}
if [ -n "$MAGICK" ] && ! pkg-config --exists $MAGICK; then
  MAGICK=ImageMagick
fi
if [ -n "$MAGICK" ]; then
  MAGICK="--with-magick=$MAGICK"
fi

# Allow forcing a particular version of Qt.  Set QT=4 or QT=5.
# If unset, Octave will decide, and it prefers version 5.
if [ -n "$QT" ]; then
  QT="--with-qt=$QT"
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.lz
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go-w,a+rX-st .

patch -p1 < $CWD/patches/imagemagick.diff  # https://savannah.gnu.org/bugs/?49653
patch -p1 < $CWD/patches/qt4opengl.diff    # https://savannah.gnu.org/bugs/?55735
patch -p1 < $CWD/patches/atlas-lib-rename.diff
autoreconf -vif

# Avoid rebuilding the documentation by making stamp-vti newer than its
# dependencies (in particular ./configure, which we may need to patch).
# If you live far enough east or west that the date contained in version.texi
# does not match that file's timestamp when printed accounting for your
# timezone, then the docs get rebuilt with your local date.
#
# The TeX environment in Slackware 14.1 fails to build the DVI and PDF
# targets in Octave 3.8.1.  Maybe it works with a recent version of TeXLive?
find . -name stamp-vti -exec touch {} +

./configure \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --sysconfdir=/etc \
  --localstatedir=/var \
  --mandir=/usr/man \
  --infodir=/usr/info \
  --docdir=/usr/doc/$PRGNAM-$VERSION \
  --disable-dependency-tracking \
  --with-openssl=auto \
  ${MAGICK} \
  ${QT} \
  --build=$ARCH-slackware-linux \
  CFLAGS="$SLKCFLAGS" \
  CXXFLAGS="$SLKCFLAGS" \
  FFLAGS="$SLKCFLAGS" \

make
make check
make install-strip DESTDIR=$PKG

find $PKG/usr/lib${LIBDIRSUFFIX} -name '*.la' -delete

find $PKG/usr/man -type f -exec gzip -9 {} +

rm -f $PKG/usr/info/dir
gzip -9 $PKG/usr/info/*.info*

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}