summaryrefslogtreecommitdiffstats
path: root/academic/ncbi-blast-plus/ncbi-blast-plus.SlackBuild
blob: eb2cb67f33e3ffde21d0ceba0c9d8b982347c0a4 (plain)
#!/bin/sh

# Slackware build script for ncbi-blast-plus

# Copyright 2013-2018 Petar Petrov slackalaxy@gmail.com
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

PRGNAM=ncbi-blast-plus
VERSION=${VERSION:-2.7.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

SRCNAM=ncbi-blast
SRCVER=2.7.1+

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i386 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

set -e

# Check for host architecture. Distribution of 32bit binaries has been
# dropped from NCBI. For more information, please read:
# http://www.ncbi.nlm.nih.gov/mailman/pipermail/blast-announce/2015q2/000112.html
if [ "$ARCH" != "x86_64" ]; then
  printf "\n\n$ARCH is not supported... \n"
  exit 1
fi

# Determine the source arch
if [ "$ARCH" = "x86_64" ]; then
  SRCARCH="x64"
else
  SRCARCH="ia32"
fi

# Construct the tarball name
TARNAME=$SRCNAM-$SRCVER-$SRCARCH-linux

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$SRCVER
tar xvf $CWD/$TARNAME.tar.gz
cd $SRCNAM-$SRCVER
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
 -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

# Install the precompiled binaries.
cd bin
install -D -m755 blast_formatter	$PKG/usr/bin/blast_formatter
install -D -m755 blastdb_aliastool	$PKG/usr/bin/blastdb_aliastool
install -D -m755 blastdbcheck		$PKG/usr/bin/blastdbcheck
install -D -m755 blastdbcmd		$PKG/usr/bin/blastdbcmd
install -D -m755 blastn			$PKG/usr/bin/blastn
install -D -m755 blastp			$PKG/usr/bin/blastp
install -D -m755 blastx			$PKG/usr/bin/blastx
install -D -m755 convert2blastmask	$PKG/usr/bin/convert2blastmask
install -D -m755 deltablast		$PKG/usr/bin/deltablast
install -D -m755 dustmasker		$PKG/usr/bin/dustmasker
install -D -m755 legacy_blast.pl	$PKG/usr/bin/legacy_blast.pl
install -D -m755 makeblastdb		$PKG/usr/bin/makeblastdb
install -D -m755 makembindex		$PKG/usr/bin/makembindex
install -D -m755 makeprofiledb		$PKG/usr/bin/makeprofiledb
install -D -m755 psiblast		$PKG/usr/bin/psiblast
install -D -m755 rpsblast		$PKG/usr/bin/rpsblast
install -D -m755 rpstblastn		$PKG/usr/bin/rpstblastn
install -D -m755 segmasker		$PKG/usr/bin/segmasker
install -D -m755 tblastn		$PKG/usr/bin/tblastn
install -D -m755 tblastx		$PKG/usr/bin/tblastx
install -D -m755 update_blastdb.pl	$PKG/usr/bin/update_blastdb.pl
install -D -m755 windowmasker		$PKG/usr/bin/windowmasker
cd ..

find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
  ChangeLog LICENSE README doc/README.txt \
  $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}