summaryrefslogtreecommitdiffstats
path: root/academic/grass/grass.SlackBuild
blob: d0066e508f24372e2b7535c6137ed07b9dadaaa6 (plain)
#!/bin/sh

# Slackware build script for grass

# Copyright 2011 David Spencer, Baildon, West Yorkshire, U.K.
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

PRGNAM=grass
VERSION=${VERSION:-6.4.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i486 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
 -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
 -exec chmod 644 {} \;

# Option handling:
# $WITHLIST has to be an array due to embedded spaces in the ffmpeg includes :-(
set -- $(echo $ENABLE | sed 's/,/ /g')
withnum=0
while [[ "$1" != "" ]]; do
  case "$1"
  in
  blas | \
  lapack | \
  sqlite )
    WITHLIST[$((withnum++))]="--with-$1"
    shift
    ;;
  mysql | mariadb )
    WITHLIST[$((withnum++))]="--with-mysql"
    WITHLIST[$((withnum++))]="--with-mysql-includes=/usr/include/mysql"
    shift
    ;;
  postgres | postgresql )
    WITHLIST[$((withnum++))]="--with-postgres"
    shift
    ;;
  ffmpeg )
    FFINCL="/usr/include/libavcodec /usr/include/libavdevice /usr/include/libavfilter \
            /usr/include/libavformat /usr/include/libavutil /usr/include/libpostproc \
            /usr/include/libswresample /usr/include/libswscale"
    WITHLIST[$((withnum++))]="--with-ffmpeg"
    WITHLIST[$((withnum++))]="--with-ffmpeg-includes=$FFINCL"
    shift
    ;;
  * )
    shift
    ;;
  esac
done

if [ "$LIBDIRSUFFIX" = "64" ]; then
  BITNESS=" --enable-64bit"
else
  BITNESS=""
fi

# geos now always enabled: it's an indirect hard dep (via gdal), and makes grass nicer :-)
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS -fpermissive" \
LDFLAGS="-ldl -lncurses" \
./configure \
  --prefix=/opt \
  --with-cxx \
  --with-fftw \
  --with-motif \
  --with-freetype \
  --with-readline \
  --with-python \
  --with-proj-share=/usr/share/proj \
  --with-cairo \
  --with-wxwidgets \
  --with-geos \
  --enable-largefile  \
  "${WITHLIST[@]}" \
  $BITNESS \
  --build=$ARCH-slackware-linux \
  --host=$ARCH-slackware-linux

make
make prefix=$PKG/opt BINDIR=$PKG/usr/bin  \
     PREFIX=$PKG/usr install

find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

# Create unversioned symlink
( cd $PKG/opt ; ln -s $PRGNAM-$VERSION $PRGNAM )

# Wrapper script fixups
sed -i -e "s;$PKG;;" -e "s;-$VERSION;;" $PKG/usr/bin/grass64
( cd $PKG/usr/bin ; ln -s grass64 $PRGNAM )

# Fix fonts path for fontcap
sed -i -e "s;$PKG;;" $PKG/opt/$PRGNAM-$VERSION/etc/fontcap

# Unversion and install the pkgconfig file
sed -i -e "s/-${VERSION}//g" grass.pc
install -D -m0644 grass.pc $PKG/usr/lib${LIBDIRSUFFIX}/pkgconfig/grass.pc

find $PKG/opt/$PRGNAM-$VERSION/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/opt/$PRGNAM-$VERSION/man -type l ) ; do \
  ln -s $( readlink $i ).gz $i.gz ; rm $i ; done

mkdir -p $PKG/usr/man/man1
cp -a \
  $PKG/opt/$PRGNAM-$VERSION/man/man1/grass6.1.gz \
  $PKG/usr/man/man1/grass.1.gz

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
  AUTHORS CHANGES COPYING ChangeLog* GPL.TXT INSTALL README REQUIREMENTS.html \
  SUBMITTING SUBMITTING_SCRIPTS SUBMITTING_TCLTK TODO \
  $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

install -D -m 0644 $CWD/$PRGNAM.desktop \
  $PKG/usr/share/applications/$PRGNAM.desktop
install -D -m 0644 gui/icons/$PRGNAM-48x48.png \
  $PKG/usr/share/pixmaps/$PRGNAM.png

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh  > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}