summaryrefslogtreecommitdiffstats
path: root/system/wine-staging/wine-staging.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/wine-staging/wine-staging.SlackBuild')
-rw-r--r--system/wine-staging/wine-staging.SlackBuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/system/wine-staging/wine-staging.SlackBuild b/system/wine-staging/wine-staging.SlackBuild
index 1f9804679f..36241a1d38 100644
--- a/system/wine-staging/wine-staging.SlackBuild
+++ b/system/wine-staging/wine-staging.SlackBuild
@@ -30,7 +30,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=wine-staging
-VERSION=${VERSION:-3.10}
+VERSION=${VERSION:-3.11}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -93,6 +93,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# from Arch Linux PKGBUILD.
+patch -Np1 < $CWD/harmony-fix.diff
+sed 's|OpenCL/opencl.h|CL/opencl.h|g' -i configure*
+
# If OPENGL=YES above, then enable opengl; otherwise, disable it.
if [ "$OPENGL" = "YES" ]; then
do_opengl="with"
@@ -108,6 +112,8 @@ fi
--${do_opengl}-opengl \
--build=$ARCH-slackware-linux
+#NUMJOBS=${NUMJOBS:-" -j12 "}
+#make $NUMJOBS || exit 1
make
make install DESTDIR=$PKG
@@ -121,6 +127,7 @@ for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; r
install -d $PKG/etc/fonts/conf.{avail,d}
install -m644 $CWD/30-win32-aliases.conf $PKG/etc/fonts/conf.avail
ln -sf /etc/fonts/conf.avail/30-win32-aliases.conf $PKG/etc/fonts/conf.d/30-win32-aliases.conf
+install -Dm 644 $CWD/wine-binfmt.conf $PKG/usr/lib/binfmt.d/wine.conf
# Create Wine menu structure:
mkdir -p $PKG/etc/xdg/menus/applications-merged