summaryrefslogtreecommitdiffstats
path: root/system/volatility/volatility.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/volatility/volatility.SlackBuild')
-rw-r--r--system/volatility/volatility.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/system/volatility/volatility.SlackBuild b/system/volatility/volatility.SlackBuild
index 911fccc8b1..48a357200d 100644
--- a/system/volatility/volatility.SlackBuild
+++ b/system/volatility/volatility.SlackBuild
@@ -21,13 +21,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
-# Updated to v2.6.1, March 2019
+# Updated deps and explicit call to python2 - v2.6.1, May, 2022
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=volatility
VERSION=${VERSION:-2.6.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,7 +80,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true