summaryrefslogtreecommitdiffstats
path: root/system/vice/vice.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/vice/vice.SlackBuild')
-rw-r--r--system/vice/vice.SlackBuild14
1 files changed, 2 insertions, 12 deletions
diff --git a/system/vice/vice.SlackBuild b/system/vice/vice.SlackBuild
index 43c1de7bc4..f745447368 100644
--- a/system/vice/vice.SlackBuild
+++ b/system/vice/vice.SlackBuild
@@ -24,7 +24,7 @@
# Initialize variables
PRGNAM=vice
-VERSION=${VERSION:-3.3}
+VERSION=${VERSION:-3.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -58,9 +58,6 @@ else
LIBDIRSUFFIX=""
fi
-# Only an external ffmpeg seems to work ATM (might change from version to version)
-if [ "${FFMPEG:-no}" = "yes" ]; then ffmpeg="--enable-external-ffmpeg"; else ffmpeg=""; fi
-
# Exit if errors encountered
set -e
@@ -86,13 +83,6 @@ sed -i 's/"\/vice_toc\.html"/"\/html\/vice_toc\.html"/g' \
sed -i "s/\/usr\/local/\/usr/g" doc/vice.* doc/html/*html
sed -i "s/\/usr\/lib\//\/usr\/lib${LIBDIRSUFFIX}\//g" doc/vice.* doc/html/*html
-# Disable PDF generation because it bombs
-sed -i "s/AM_CONDITIONAL(BUILD_PDF, true)/AM_CONDITIONAL(BUILD_PDF, false)/g" \
- configure.ac
-
-# Don't install fonts in $HOME and run fc-cache on the build system
-sed -i -e '/@HAVE_FC_CACHE_TRUE@/d' data/fonts/Makefile.am
-
autoreconf -vif
# Configure the software
@@ -105,7 +95,7 @@ CXXFLAGS="$SLKCFLAGS" \
--localstatedir=/var \
--mandir=/usr/man \
--infodir=/usr/info \
- $ffmpeg \
+ --enable-shared-ffmpeg \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--with-x \
--enable-quicktime \