summaryrefslogtreecommitdiffstats
path: root/system/tmuxp/tmuxp.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/tmuxp/tmuxp.SlackBuild')
-rw-r--r--system/tmuxp/tmuxp.SlackBuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/system/tmuxp/tmuxp.SlackBuild b/system/tmuxp/tmuxp.SlackBuild
index 91a66772aa..ddfe483074 100644
--- a/system/tmuxp/tmuxp.SlackBuild
+++ b/system/tmuxp/tmuxp.SlackBuild
@@ -24,11 +24,12 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# 20220512 46and2: Updated version, fix README, New maintainer.
+# 20220919 46and2: Updated version, change build process.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=tmuxp
-VERSION=${VERSION:-1.11.1}
+VERSION=${VERSION:-1.15.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -82,7 +83,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true