summaryrefslogtreecommitdiffstats
path: root/system/slim/slim.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/slim/slim.SlackBuild')
-rw-r--r--system/slim/slim.SlackBuild35
1 files changed, 19 insertions, 16 deletions
diff --git a/system/slim/slim.SlackBuild b/system/slim/slim.SlackBuild
index 95eba88c03..c637d8e963 100644
--- a/system/slim/slim.SlackBuild
+++ b/system/slim/slim.SlackBuild
@@ -3,6 +3,8 @@
# Slackware build script for SLiM
# Copyright 2006 Martin Lefebvre <dadexter@gmail.com>
+# Copyright 2007-2009 Frank Caraballo <fecaraballo{at}gmail{dot}com>
+# Copyright 2010,2013 Niels Horn, Rio de Janeiro, Brazil
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,13 +24,10 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# Maintained until v1.3.1 by Frank Caraballo <fecaraballo{at}gmail{dot}com>
-
-# As of v1.3.2 maintained by Niels Horn <niels.horn@gmail.com>
-# revision date: 2010/09/15
+# revision date: 2013/03/30
PRGNAM=slim
-VERSION=${VERSION:-1.3.2}
+VERSION=${VERSION:-1.3.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -45,11 +44,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-# Since PAM is not included on a stock Slackware system, default to NO.
-# If you have PAM installed, then run the build script like this:
-# USE_PAM=1 ./slim.SlackBuild
-USE_PAM=${USE_PAM:-""}
-
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
@@ -82,13 +76,19 @@ find . \
# Correct the path used for suspend:
patch -p0 < $CWD/slim.conf.patch
-# Use libpng14
-patch -p1 < $CWD/slim-1.3.2-use_libpng14.patch
+# Fix location of man-pages
+sed "s/share\/man/man/" -i CMakeLists.txt
-make \
- CFLAGS+="$SLKCFLAGS" \
- USE_PAM=${USE_PAM}
-make install DESTDIR=$PKG
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
# Don't overwrite existing config file:
mv $PKG/etc/slim.conf $PKG/etc/slim.conf.new
@@ -100,6 +100,9 @@ tar xvf $CWD/slackware-black.tar.bz2 -C $PKG/usr/share/slim/themes
mkdir -p $PKG/etc/logrotate.d
cat $CWD/slim.logrotate > $PKG/etc/logrotate.d/slim.new
+# Kill the incorrectly-placed (and useless anyway) systemd stuff
+rm -rf $PKG/usr/usr
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true