summaryrefslogtreecommitdiffstats
path: root/system/sbsigntools/sbsigntools.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/sbsigntools/sbsigntools.SlackBuild')
-rw-r--r--system/sbsigntools/sbsigntools.SlackBuild33
1 files changed, 10 insertions, 23 deletions
diff --git a/system/sbsigntools/sbsigntools.SlackBuild b/system/sbsigntools/sbsigntools.SlackBuild
index f9701591ff..5f64805828 100644
--- a/system/sbsigntools/sbsigntools.SlackBuild
+++ b/system/sbsigntools/sbsigntools.SlackBuild
@@ -23,15 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=sbsigntools
-VERSION=${VERSION:-0.7}
+VERSION=${VERSION:-0.9.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-CCAN_VERSION=${CCAN_VERSION:-0.0.2}
-
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -42,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -62,23 +60,9 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+# The tarball is generated from a clone --recursive of the git repository
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
cd $PRGNAM-$VERSION
-tar -xvf $CWD/ccan-$CCAN_VERSION.tar.gz -C lib/ccan.git
-
-# Next 2 patches taken from
-# https://build.opensuse.org/package/show/home:jejb1:UEFI/sbsigntools?rev=16
-# Fixes build on 32-bit.
-patch -p1 -i $CWD/fix_efi_arch.patch
-
-# Creates changelog and stops git from being called.
-patch -p1 -i $CWD/autogen.patch
-
-# Suppress "not git repo messages"- they're evaluated by the makefile but don't
-# actually get run so it's just noise.
-patch -p1 -i $CWD/ccan_makefile.patch
-rm lib/ccan.git/Makefile-web
-
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -86,7 +70,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-./autogen.sh
+sed -i "s|/usr/lib$LIBDIRSUFFIX/efi|/usr/lib$LIBDIRSUFFIX/gnuefi|" configure.ac
+
+NOCONFIGURE=1 ./autogen.sh
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \