summaryrefslogtreecommitdiffstats
path: root/system/sandy/sandy.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/sandy/sandy.SlackBuild')
-rw-r--r--system/sandy/sandy.SlackBuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/system/sandy/sandy.SlackBuild b/system/sandy/sandy.SlackBuild
index aa6a35c3b7..3350742aa7 100644
--- a/system/sandy/sandy.SlackBuild
+++ b/system/sandy/sandy.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for sandy
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
@@ -16,10 +16,13 @@
# - update for latest git (20140727, 3 days newer than last update!)
# - *really* fix homepage in .info file
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=sandy
VERSION=${VERSION:-0.4_20140727}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -29,7 +32,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -57,11 +64,8 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
# just in case...
sed -i "s,\<lib\>,lib$LIBDIRSUFFIX,g" config.mk
@@ -83,4 +87,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE