summaryrefslogtreecommitdiffstats
path: root/system/rodent/rodent.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/rodent/rodent.SlackBuild')
-rw-r--r--system/rodent/rodent.SlackBuild29
1 files changed, 12 insertions, 17 deletions
diff --git a/system/rodent/rodent.SlackBuild b/system/rodent/rodent.SlackBuild
index 098e482997..214294b9a1 100644
--- a/system/rodent/rodent.SlackBuild
+++ b/system/rodent/rodent.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for rodent
-# Copyright 2011-2012 Roberto Neri, Palermo, Italy
+# Copyright 2011-2013 Roberto Neri, Palermo, Italy
#
# All rights reserved.
#
@@ -24,7 +24,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=rodent
-VERSION=${VERSION:-4.8.0}
+VERSION=${VERSION:-5.0.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -57,7 +57,11 @@ fi
# The experimental plugins are disabled by default but can be enabled
# by passing EXPERIMENTAL=yes to the script
-EXPERIMENTAL=${EXPERIMENTAL:-no}
+if [ "${EXPERIMENTAL:-no}" = "yes" ]; then
+ ENABLE_EXPERIMENTAL="enable"
+else
+ ENABLE_EXPERIMENTAL="disable"
+fi
set -e
@@ -74,9 +78,6 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Fix Build/plugins/Makefile
-patch -p1 < $CWD/$PRGNAM-$VERSION.diff
-
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -84,19 +85,14 @@ CXXFLAGS="$SLKCFLAGS" \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--mandir=/usr/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
- --enable-experimental=$EXPERIMENTAL \
+ --$ENABLE_EXPERIMENTAL-experimental \
--build=$ARCH-slackware-linux
make
-
-# Note: the manual (RTFM.pdf) is installed in /usr/share/doc/rfm-Delta
-# This could be overridden by passing docdir=/usr/doc/$PRGNAM-$VERSION
-# to "make install", but that would break the "Help" function, so it's
-# better to leave it in its non-standard location
-# =========
-# Yes, but that's a bug. Edscott should fix that. :)
-# --rworkman
-make install DESTDIR=$PKG
+# Install the manual (RTFM.pdf) in the standard Slackware location...
+make install DESTDIR=$PKG rtfmdir=/usr/doc/$PRGNAM-$VERSION
+# ...and create a symlink so it can be opened by the Help function
+( cd $PKG/usr/doc ; ln -sf $PRGNAM-$VERSION rfm )
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -104,7 +100,6 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
AUTHORS ChangeLog COPYING INSTALL NEWS README TODO WISHLIST \
$PKG/usr/doc/$PRGNAM-$VERSION