summaryrefslogtreecommitdiffstats
path: root/system/rfdump
diff options
context:
space:
mode:
Diffstat (limited to 'system/rfdump')
-rw-r--r--system/rfdump/02_configure.in-preserve-CFLAGS.patch44
-rw-r--r--system/rfdump/rfdump.SlackBuild35
-rw-r--r--system/rfdump/rfdump.info2
3 files changed, 67 insertions, 14 deletions
diff --git a/system/rfdump/02_configure.in-preserve-CFLAGS.patch b/system/rfdump/02_configure.in-preserve-CFLAGS.patch
new file mode 100644
index 0000000000..1de2ed2d69
--- /dev/null
+++ b/system/rfdump/02_configure.in-preserve-CFLAGS.patch
@@ -0,0 +1,44 @@
+From: Lukas Schwaighofer <lukas@schwaighofer.name>
+Date: Thu, 20 Apr 2017 23:26:01 +0200
+Subject: configure.in: preserve CFLAGS
+Forwarded: https://lists.alioth.debian.org/pipermail/pkg-security-team/Week-of-Mon-20170417/001267.html
+
+This patch fixes two problems with configure.in:
+* The [ and ] characters, which are part of the perl command, get
+ removed by m4/autoconf processing. The patch replaces them by @<:@
+ and @:>@ so the perl snippet ends up correctly in the configure script
+* Do not remove `-g` if it was explicitly included in the CFLAGS given
+ to configure (the user knows best). Instead only remove `-g` from the
+ default CFLAGS.
+---
+ configure.in | 9 +++------
+ 1 file changed, 3 insertions(+), 6 deletions(-)
+
+--- a/configure.in
++++ b/configure.in
+@@ -4,6 +4,8 @@
+ AM_INIT_AUTOMAKE([1.9 foreign])
+ AM_CONFIG_HEADER(config.h)
+
++# remove -g from the default flags
++: ${CFLAGS="-O2"}
+ AC_PROG_CC
+ AM_PROG_CC_STDC
+ AC_HEADER_STDC
+@@ -27,15 +29,10 @@
+ AC_ARG_ENABLE(debug, [ --enable-debug turn on debugging], enable_debug=yes, enable_debug=no)
+ if test "x$enable_debug" = "xyes"; then
+ # remove -O flags from CFLAGS
+- CFLAGS=`perl -e '$ARGV[0]=~s/-O\d?//g;print $ARGV[0]' -- "$CFLAGS"`
++ CFLAGS=`perl -e '$ARGV@<:@0@:>@=~s/-O\d?//g;print $ARGV@<:@0@:>@' -- "$CFLAGS"`
+ # add debug parameters
+ CFLAGS="$CFLAGS -g -DDEBUG -DDOJDEBUG"
+ AC_MSG_RESULT(yes)
+-else
+- # remove -g flags from CFLAGS
+- CFLAGS=`perl -e '$ARGV[0]=~s/-g//g;print $ARGV[0]' -- "$CFLAGS"`
+- CFLAGS="$CFLAGS -O2"
+- AC_MSG_RESULT(no)
+ fi
+
+ # produce Makefiles
diff --git a/system/rfdump/rfdump.SlackBuild b/system/rfdump/rfdump.SlackBuild
index 67c3fadc6c..a2ba52462a 100644
--- a/system/rfdump/rfdump.SlackBuild
+++ b/system/rfdump/rfdump.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for rfdump
-# Copyright 2017 Ebben Aries, Colorado, USA
+# Copyright 2017 Ebben Aries <slackbuilds@dscp.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220210 bkw: Modified by SlackBuilds.org, to fix the build on 15.0.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=rfdump
VERSION=${VERSION:-1.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +40,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -65,14 +74,17 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+# 20220210 bkw: make the configure script actually use CFLAGS from
+# the env (patch comes from Debian).
+patch -p1 < $CWD/02_configure.in-preserve-CFLAGS.patch
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
+CFLAGS="$SLKCFLAGS -fcommon" \
+LDFLAGS="-lexpat" \
./configure \
- LDFLAGS="-lexpat" \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
@@ -82,10 +94,7 @@ CXXFLAGS="$SLKCFLAGS" \
--build=$ARCH-slackware-linux
make
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+make install-strip DESTDIR=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS COPYING INSTALL NEWS README TODO $PKG/usr/doc/$PRGNAM-$VERSION
@@ -96,4 +105,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/rfdump/rfdump.info b/system/rfdump/rfdump.info
index 4390e11b68..ea5e6e4260 100644
--- a/system/rfdump/rfdump.info
+++ b/system/rfdump/rfdump.info
@@ -7,4 +7,4 @@ DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="Ebben Aries"
-EMAIL="e@dscp.org"
+EMAIL="slackbuilds@dscp.org"