summaryrefslogtreecommitdiffstats
path: root/system/renameutils/patches/install-exec-local-fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'system/renameutils/patches/install-exec-local-fix.patch')
-rw-r--r--system/renameutils/patches/install-exec-local-fix.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/system/renameutils/patches/install-exec-local-fix.patch b/system/renameutils/patches/install-exec-local-fix.patch
new file mode 100644
index 0000000000..7aee3e4c89
--- /dev/null
+++ b/system/renameutils/patches/install-exec-local-fix.patch
@@ -0,0 +1,27 @@
+Description: Fix typo in install target of Makefile
+Forwarded: emailed
+Author: Francois Marier <francois@debian.org>
+Last-Update: 2012-05-06
+
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -49,7 +49,7 @@ all-local:
+ @[ -f icp ] || (echo $(LN_S) icmd icp ; $(LN_S) icmd icp)
+
+ install-exec-local:
+- $(mkdir_p) $(DESTDIR)($bindir)
++ $(mkdir_p) $(DESTDIR)$(bindir)
+ @[ -f $(DESTDIR)$(bindir)/qmv ] || (echo $(LN_S) qcmd $(DESTDIR)$(bindir)/qmv ; $(LN_S) qcmd $(DESTDIR)$(bindir)/qmv)
+ @[ -f $(DESTDIR)$(bindir)/qcp ] || (echo $(LN_S) qcmd $(DESTDIR)$(bindir)/qcp ; $(LN_S) qcmd $(DESTDIR)$(bindir)/qcp)
+ @[ -f $(DESTDIR)$(bindir)/imv ] || (echo $(LN_S) icmd $(DESTDIR)$(bindir)/imv ; $(LN_S) icmd $(DESTDIR)$(bindir)/imv)
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -1577,7 +1577,7 @@ all-local:
+ @[ -f icp ] || (echo $(LN_S) icmd icp ; $(LN_S) icmd icp)
+
+ install-exec-local:
+- $(mkdir_p) $(DESTDIR)($bindir)
++ $(mkdir_p) $(DESTDIR)$(bindir)
+ @[ -f $(DESTDIR)$(bindir)/qmv ] || (echo $(LN_S) qcmd $(DESTDIR)$(bindir)/qmv ; $(LN_S) qcmd $(DESTDIR)$(bindir)/qmv)
+ @[ -f $(DESTDIR)$(bindir)/qcp ] || (echo $(LN_S) qcmd $(DESTDIR)$(bindir)/qcp ; $(LN_S) qcmd $(DESTDIR)$(bindir)/qcp)
+ @[ -f $(DESTDIR)$(bindir)/imv ] || (echo $(LN_S) icmd $(DESTDIR)$(bindir)/imv ; $(LN_S) icmd $(DESTDIR)$(bindir)/imv)