summaryrefslogtreecommitdiffstats
path: root/system/rename/rename.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/rename/rename.SlackBuild')
-rw-r--r--system/rename/rename.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/system/rename/rename.SlackBuild b/system/rename/rename.SlackBuild
index aaf3e19d96..d4ed9a8a03 100644
--- a/system/rename/rename.SlackBuild
+++ b/system/rename/rename.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=rename
VERSION=${VERSION:-1.2}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -71,6 +71,9 @@ find -L . \
python setup.py install --root=$PKG
+mkdir -p $PKG/usr/bin
+mv $PKG/usr/bin/rename $PKG/usr/bin/pyrename
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true