summaryrefslogtreecommitdiffstats
path: root/system/rdiff-backup
diff options
context:
space:
mode:
Diffstat (limited to 'system/rdiff-backup')
-rw-r--r--system/rdiff-backup/README33
-rw-r--r--system/rdiff-backup/rdiff-backup.SlackBuild28
-rw-r--r--system/rdiff-backup/rdiff-backup.info12
3 files changed, 46 insertions, 27 deletions
diff --git a/system/rdiff-backup/README b/system/rdiff-backup/README
index fc58cd77c0..0d5c202d04 100644
--- a/system/rdiff-backup/README
+++ b/system/rdiff-backup/README
@@ -1,13 +1,20 @@
-rdiff-backup backs up one directory to another, possibly over a
-network. The target directory ends up a copy of the source directory,
-but extra reverse diffs are stored in a special subdirectory of that
-target directory, so you can still recover files lost some time
-ago. The idea is to combine the best features of a mirror and an
-incremental backup. rdiff-backup also preserves subdirectories, hard
-links, dev files, permissions, uid/gid ownership, modification times,
-extended attributes, acls, and resource forks. Also, rdiff-backup
-can operate in a bandwidth efficient manner over a pipe, like
-rsync. Thus you can use rdiff-backup and ssh to securely back a
-hard drive up to a remote location, and only the differences will
-be transmitted. Finally, rdiff-backup is easy to use and settings
-have sensical defaults.
+rdiff-backup is a simple backup tool which can be used locally and
+remotely, on Linux and Windows, and even cross-platform between both.
+Users have reported using it successfully on FreeBSD and MacOS X.
+
+Beside its ease of use, one of the main advantages of rdiff-backup is
+that it does use the same efficient protocol as rsync to transfer and
+store data. Because rdiff-backup only stores the differences from the
+previous backup to the next one (a so called reverse incremental
+backup), the latest backup is always a full backup, making it easiest
+and fastest to restore the most recent backups, combining the space
+advantages of incremental backups while keeping the speed advantages
+of full backups (at least for recent ones).
+
+If the optional (runtime) dependencies pylibacl and pyxattr are
+installed, rdiff-backup will support Access Control Lists and Extended
+Attributes provided the file system(s) also support these features.
+
+IMPORTANT: rdiff-backup 2.x is wire-incompatible with versions 1.x, for
+local backups there's no problem but if you backup remotely you have to
+use the same version of rdiff-backup in the client and server.
diff --git a/system/rdiff-backup/rdiff-backup.SlackBuild b/system/rdiff-backup/rdiff-backup.SlackBuild
index 02fe2055a6..1177f47818 100644
--- a/system/rdiff-backup/rdiff-backup.SlackBuild
+++ b/system/rdiff-backup/rdiff-backup.SlackBuild
@@ -1,6 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for rdiff-backup
+# Copyright 2022-2023 Eugene Wissner, Mannheim, Germany
+#
# Copyright (C) 2007 paul wisehart wise@lupulin.net
# All rights reserved.
#
@@ -23,20 +25,30 @@
# Modified by the SlackBuilds.org project
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=rdiff-backup
-VERSION=${VERSION:-1.2.8}
+VERSION=${VERSION:-2.2.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -55,7 +67,7 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
sed -i 's|share/man/|man/|g' setup.py || exit 1
-python setup.py install --prefix=/usr --root=$PKG || exit 1
+python3 setup.py install --prefix=/usr --root=$PKG || exit 1
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -66,13 +78,13 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
)
mkdir -p $PKG/usr/doc
-mv $PKG/usr/share/doc/$PRGNAM-$VERSION $PKG/usr/doc
+mv $PKG/usr/share/doc/$PRGNAM $PKG/usr/doc/$PRGNAM-$VERSION
cp -a examples.html $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-rm -rf $PKG/usr/share
+rm -rf $PKG/usr/share/doc
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/rdiff-backup/rdiff-backup.info b/system/rdiff-backup/rdiff-backup.info
index fe58d9070b..94e35800cc 100644
--- a/system/rdiff-backup/rdiff-backup.info
+++ b/system/rdiff-backup/rdiff-backup.info
@@ -1,10 +1,10 @@
PRGNAM="rdiff-backup"
-VERSION="1.2.8"
-HOMEPAGE="http://rdiff-backup.nongnu.org/"
-DOWNLOAD="http://savannah.nongnu.org/download/rdiff-backup/rdiff-backup-1.2.8.tar.gz"
-MD5SUM="1a94dc537fcf74d6a3a80bd27808e77b"
+VERSION="2.2.6"
+HOMEPAGE="https://rdiff-backup.net/"
+DOWNLOAD="https://download.dlackware.com/hosted-sources/rdiff-backup/rdiff-backup-2.2.6.tar.gz"
+MD5SUM="cc055b501f004c1828664755ae039c28"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="librsync"
-MAINTAINER="Ricardo J. Barberis"
-EMAIL="ricardo.barberis@gmail.com"
+MAINTAINER="Eugene Wissner"
+EMAIL="belka@caraus.de"