summaryrefslogtreecommitdiffstats
path: root/system/rdiff-backup/rdiff-backup.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/rdiff-backup/rdiff-backup.SlackBuild')
-rw-r--r--system/rdiff-backup/rdiff-backup.SlackBuild28
1 files changed, 20 insertions, 8 deletions
diff --git a/system/rdiff-backup/rdiff-backup.SlackBuild b/system/rdiff-backup/rdiff-backup.SlackBuild
index 02fe2055a6..1177f47818 100644
--- a/system/rdiff-backup/rdiff-backup.SlackBuild
+++ b/system/rdiff-backup/rdiff-backup.SlackBuild
@@ -1,6 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for rdiff-backup
+# Copyright 2022-2023 Eugene Wissner, Mannheim, Germany
+#
# Copyright (C) 2007 paul wisehart wise@lupulin.net
# All rights reserved.
#
@@ -23,20 +25,30 @@
# Modified by the SlackBuilds.org project
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=rdiff-backup
-VERSION=${VERSION:-1.2.8}
+VERSION=${VERSION:-2.2.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -55,7 +67,7 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
sed -i 's|share/man/|man/|g' setup.py || exit 1
-python setup.py install --prefix=/usr --root=$PKG || exit 1
+python3 setup.py install --prefix=/usr --root=$PKG || exit 1
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -66,13 +78,13 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
)
mkdir -p $PKG/usr/doc
-mv $PKG/usr/share/doc/$PRGNAM-$VERSION $PKG/usr/doc
+mv $PKG/usr/share/doc/$PRGNAM $PKG/usr/doc/$PRGNAM-$VERSION
cp -a examples.html $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-rm -rf $PKG/usr/share
+rm -rf $PKG/usr/share/doc
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE