summaryrefslogtreecommitdiffstats
path: root/system/maintboot
diff options
context:
space:
mode:
Diffstat (limited to 'system/maintboot')
-rw-r--r--system/maintboot/maintboot.SlackBuild26
-rw-r--r--system/maintboot/maintboot.info4
2 files changed, 17 insertions, 13 deletions
diff --git a/system/maintboot/maintboot.SlackBuild b/system/maintboot/maintboot.SlackBuild
index 403e527b7f..1b33cbc765 100644
--- a/system/maintboot/maintboot.SlackBuild
+++ b/system/maintboot/maintboot.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for maintboot
@@ -22,26 +22,33 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=maintboot
VERSION=${VERSION:-0.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -60,17 +67,14 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-if [ -r $CWD/v$VERSION.tar.gz ]; then
- mv $CWD/v$VERSION.tar.gz $CWD/$PRGNAM-$VERSION.tar.gz
-fi
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} + -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
python3 setup.py install --root=$PKG
@@ -85,4 +89,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/maintboot/maintboot.info b/system/maintboot/maintboot.info
index 09d03779e5..720ae104c5 100644
--- a/system/maintboot/maintboot.info
+++ b/system/maintboot/maintboot.info
@@ -1,10 +1,10 @@
PRGNAM="maintboot"
VERSION="0.1.0"
HOMEPAGE="https://github.com/g2p/maintboot"
-DOWNLOAD="https://github.com/g2p/maintboot/archive/v0.1.0.tar.gz"
+DOWNLOAD="https://github.com/g2p/maintboot/archive/v0.1.0/maintboot-0.1.0.tar.gz"
MD5SUM="6c58f3cd4cc944c22cb0c03054c132e6"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3"
+REQUIRES=""
MAINTAINER="Nikos Giotis"
EMAIL="nikos.giotis@gmail.com"