summaryrefslogtreecommitdiffstats
path: root/system/linuxconsoletools/linuxconsoletools.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/linuxconsoletools/linuxconsoletools.SlackBuild')
-rw-r--r--system/linuxconsoletools/linuxconsoletools.SlackBuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/system/linuxconsoletools/linuxconsoletools.SlackBuild b/system/linuxconsoletools/linuxconsoletools.SlackBuild
index 53593fb9bb..280fd139b6 100644
--- a/system/linuxconsoletools/linuxconsoletools.SlackBuild
+++ b/system/linuxconsoletools/linuxconsoletools.SlackBuild
@@ -29,8 +29,10 @@
# 20160726 bkw: update for v1.5.1
+# 20161015 bkw: update for v1.6.0
+
PRGNAM=linuxconsoletools
-VERSION=${VERSION:-1.5.1}
+VERSION=${VERSION:-1.6.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -79,23 +81,18 @@ find -L . \
# install manpages in /usr/man instead of /usr/share/man
sed -i 's,share/man,man,g' docs/Makefile
-# No ./configure provided
-make CFLAGS="$SLKCFLAGS" PREFIX=/usr
+# -Wl,-s strips the bins.
+make CFLAGS="$SLKCFLAGS" LDFLAGS="-Wl,-s" PREFIX=/usr
make install DESTDIR=$PKG PREFIX=/usr
+gzip -9 $PKG/usr/man/man?/*.?
mkdir -p $PKG/lib/udev/rules.d/
install -m 0644 $CWD/90-joystick.rules $PKG/lib/udev/rules.d/90-joystick.rules
mkdir -p $PKG/var/lib/joystick
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $(find $PKG/usr/man -type l) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING NEWS README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING NEWS README docs/*.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install