summaryrefslogtreecommitdiffstats
path: root/system/linuxconsoletools/linuxconsoletools.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/linuxconsoletools/linuxconsoletools.SlackBuild')
-rw-r--r--system/linuxconsoletools/linuxconsoletools.SlackBuild27
1 files changed, 22 insertions, 5 deletions
diff --git a/system/linuxconsoletools/linuxconsoletools.SlackBuild b/system/linuxconsoletools/linuxconsoletools.SlackBuild
index 129224725c..1e0c50fe5c 100644
--- a/system/linuxconsoletools/linuxconsoletools.SlackBuild
+++ b/system/linuxconsoletools/linuxconsoletools.SlackBuild
@@ -1,8 +1,9 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for linuxconsoletools
# Copyright 2011-2012 Roberto Neri, Palermo, Italy
+# Copyright 2021 B. Watson <urchlay@slackware.uk>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,6 +23,9 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20221228 bkw: update for v1.8.1
+# 20210223 bkw: update for v1.7.1
+# 20191129 bkw: update for v1.7.0, document new optional SDL2 dep.
# 20181030 bkw: add GPM_COMPAT=yes option, minor cleanups, BUILD=2
# 20161015 bkw: update for v1.6.0
# 20160726 bkw: update for v1.5.1
@@ -29,10 +33,13 @@
# 20140315 bkw: took over maintenance, updated for 1.4.7,
# replaced patch with a bit of sed.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=linuxconsoletools
-VERSION=${VERSION:-1.6.0}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.8.1}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -42,7 +49,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -73,6 +84,12 @@ chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+# 20191129 bkw: allow building without SDL2 installed.
+if ! pkg-config --exists sdl2; then
+ sed -i '/^PROGRAMS/s,ffmvforce ,,' utils/Makefile
+ sed -i 's,ffmvforce\.1 ,,' docs/Makefile
+fi
+
# install manpages in /usr/man instead of /usr/share/man
sed -i 's,share/man,man,g' docs/Makefile
@@ -102,4 +119,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE