summaryrefslogtreecommitdiffstats
path: root/system/letsencrypt/letsencrypt.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/letsencrypt/letsencrypt.SlackBuild')
-rw-r--r--system/letsencrypt/letsencrypt.SlackBuild30
1 files changed, 20 insertions, 10 deletions
diff --git a/system/letsencrypt/letsencrypt.SlackBuild b/system/letsencrypt/letsencrypt.SlackBuild
index 6c4c002267..a998f4be7d 100644
--- a/system/letsencrypt/letsencrypt.SlackBuild
+++ b/system/letsencrypt/letsencrypt.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for letsencrypt
-# Copyright 2015-2019 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2015-2023 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,11 +22,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=letsencrypt
SRCNAM=certbot
-VERSION=${VERSION:-1.0.0}
+VERSION=${VERSION:-2.9.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,7 +39,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -80,24 +90,24 @@ done
# install acme-protocol first
cd acme
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
# install letsencrypt client
cd ../certbot
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
# install apache plugin
cd ../certbot-apache
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
cd ..
# install nginx plugin
#cd ../certbot-nginx
-#python setup.py install --root=$PKG
+#python3 setup.py install --root=$PKG
# We include default options for Apache
mkdir -p $PKG/etc/letsencrypt/
-cp $PKG/usr/lib${LIBDIRSUFFIX}/python2.7/site-packages/certbot_apache/_internal/options-ssl-apache.conf \
+cp $PKG/usr/lib${LIBDIRSUFFIX}/python$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')/site-packages/certbot_apache/_internal/tls_configs/current-options-ssl-apache.conf \
$PKG/etc/letsencrypt/options-ssl-apache.conf
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
@@ -114,4 +124,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE