summaryrefslogtreecommitdiffstats
path: root/system/iotop/iotop.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/iotop/iotop.SlackBuild')
-rw-r--r--system/iotop/iotop.SlackBuild15
1 files changed, 5 insertions, 10 deletions
diff --git a/system/iotop/iotop.SlackBuild b/system/iotop/iotop.SlackBuild
index 64eaa636dd..2d3a42a702 100644
--- a/system/iotop/iotop.SlackBuild
+++ b/system/iotop/iotop.SlackBuild
@@ -4,16 +4,14 @@
# Written by Audrius Kažukauskas <audrius@neutrino.lt>
PRGNAM=iotop
-VERSION=${VERSION:-0.4}
+VERSION=${VERSION:-0.4.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -38,15 +36,12 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py install --root=$PKG
+sed -i 's|share/man/man1|man/man1|' setup.py
-mv $PKG/usr/share/man $PKG/usr
-rm -rf $PKG/usr/share
+python setup.py install --root=$PKG
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING NEWS THANKS $PKG/usr/doc/$PRGNAM-$VERSION