summaryrefslogtreecommitdiffstats
path: root/system/hashcat
diff options
context:
space:
mode:
Diffstat (limited to 'system/hashcat')
-rw-r--r--system/hashcat/README10
-rw-r--r--system/hashcat/hashcat.SlackBuild55
-rw-r--r--system/hashcat/hashcat.info8
-rw-r--r--system/hashcat/slack-desc8
4 files changed, 50 insertions, 31 deletions
diff --git a/system/hashcat/README b/system/hashcat/README
index 030ea13c73..3e32498d6f 100644
--- a/system/hashcat/README
+++ b/system/hashcat/README
@@ -1,5 +1,7 @@
-hashcat is the world's fastest and most advanced password recovery
-utility, supporting five unique modes of attack for over 160
-highly-optimized hashing algorithms. hashcat currently supports CPU's,
-GPU's other hardware-accelerators on Linux, Windows and OSX, and has
+hashcat (advanced password recovery)
+
+hashcat is the world's fastest and most advanced password recovery
+utility, supporting five unique modes of attack for over 160
+highly-optimized hashing algorithms. hashcat currently supports CPUs,
+GPUs, other hardware-accelerators on Linux, Windows and OSX, and has
facilities to help enable distributed password cracking.
diff --git a/system/hashcat/hashcat.SlackBuild b/system/hashcat/hashcat.SlackBuild
index 6bc177144f..5e41302610 100644
--- a/system/hashcat/hashcat.SlackBuild
+++ b/system/hashcat/hashcat.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for hashcat
@@ -22,10 +22,17 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220211 bkw: Modified by SlackBuilds.org: updated for v6.2.4. The
+# old version wouldn't build on 15.0, and it was getting a bit long
+# in the tooth anyway.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=hashcat
-VERSION=${VERSION:-3.5.0}
+VERSION=${VERSION:-6.2.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +42,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -65,28 +76,34 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+# 20220211 bkw: build stripped.
+SLKCFLAGS+=" -Wl,-s"
-for i in $(ls $CWD/patches); do
- patch -p0 < $CWD/patches/$i
-done
+# 20220211 bkw: lots of make arguments, deduplicate.
+runmake() {
+ make "$@" \
+ CC="gcc $SLKCFLAGS" \
+ CXX="g++ $SLKCFLAGS" \
+ PREFIX=/usr \
+ LIBRARY_FOLDER=/usr/lib$LIBDIRSUFFIX \
+ DOCUMENT_FOLDER=/usr/doc/$PRGNAM-$VERSION \
+ DESTDIR=$PKG
+}
-sed -i "s|/lib|/lib${LIBDIRSUFFIX}|" src/Makefile
-sed -i "s|share/doc/hashcat|doc/$PRGNAM-$VERSION|" src/Makefile
-make
-make install DESTDIR=$PKG
+runmake
+runmake install
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+chmod -x $PKGDOC/*.sh $PKGDOC/extra/tab_completion/install
+cp -a README.md $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a docs/* $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/hashcat/hashcat.info b/system/hashcat/hashcat.info
index 2dd1270653..f1cd6ea160 100644
--- a/system/hashcat/hashcat.info
+++ b/system/hashcat/hashcat.info
@@ -1,10 +1,10 @@
PRGNAM="hashcat"
-VERSION="3.5.0"
+VERSION="6.2.4"
HOMEPAGE="https://hashcat.net/hashcat/"
-DOWNLOAD="https://github.com/hashcat/hashcat/archive/v3.5.0/hashcat-3.5.0.tar.gz"
-MD5SUM="4cb174751d2ca9da5eec5a5e97d10d38"
+DOWNLOAD="https://github.com/hashcat/hashcat/archive/v6.2.4/hashcat-6.2.4.tar.gz"
+MD5SUM="afa750eba597503f502d410a5a7a0c9f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="opencl-headers"
+REQUIRES=""
MAINTAINER="Andre Fernando"
EMAIL="ando344@gmail.com"
diff --git a/system/hashcat/slack-desc b/system/hashcat/slack-desc
index d937799af9..6fa5c2d5d6 100644
--- a/system/hashcat/slack-desc
+++ b/system/hashcat/slack-desc
@@ -10,10 +10,10 @@ hashcat: hashcat (advanced password recovery)
hashcat:
hashcat: hashcat is the world's fastest and most advanced password recovery
hashcat: utility, supporting five unique modes of attack for over 160
-hashcat: highly-optimized hashing algorithms. hashcat currently supports
-hashcat: CPU's, GPU's other hardware-accelerators on Linux, Windows and OSX,
-hashcat: and has facilities to help enable distributed password cracking.
+hashcat: highly-optimized hashing algorithms. hashcat currently supports CPUs,
+hashcat: GPUs, other hardware-accelerators on Linux, Windows and OSX, and has
+hashcat: facilities to help enable distributed password cracking.
+hashcat:
hashcat:
-hashcat: Homepage: https://hashcat.net/hashcat/
hashcat:
hashcat: