summaryrefslogtreecommitdiffstats
path: root/system/gnomint/patches/01_cflags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'system/gnomint/patches/01_cflags.patch')
-rw-r--r--system/gnomint/patches/01_cflags.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/system/gnomint/patches/01_cflags.patch b/system/gnomint/patches/01_cflags.patch
new file mode 100644
index 0000000000..abf31b6357
--- /dev/null
+++ b/system/gnomint/patches/01_cflags.patch
@@ -0,0 +1,15 @@
+Author: Daniel Baumann <daniel@debian.org>
+Description:
+ Don't hardcode CFLAGS and respect the environment (Closes: #634395).
+
+--- gnomint-1.3.0.orig/configure.ac
++++ gnomint-1.3.0/configure.ac
+@@ -182,7 +182,7 @@
+
+ dnl
+ if test "x$GCC" = "xyes"; then
+- CFLAGS="-Wall -Werror "
++ CFLAGS="${CFLAGS:--Wall}"
+ if test "x$use_debug" = "xYes"; then
+ CFLAGS="$CFLAGS -g -O0"
+ fi