summaryrefslogtreecommitdiffstats
path: root/system/gnomint/gnomint.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/gnomint/gnomint.SlackBuild')
-rw-r--r--system/gnomint/gnomint.SlackBuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/system/gnomint/gnomint.SlackBuild b/system/gnomint/gnomint.SlackBuild
index 9f043f0c90..7a4f44ca82 100644
--- a/system/gnomint/gnomint.SlackBuild
+++ b/system/gnomint/gnomint.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for gnomint
-# Copyright 2012-2016 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
+# Copyright 2012-2020 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=gnomint
VERSION=${VERSION:-1.3.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -71,9 +71,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-cp Makefile.in m4/
+# Apply debian patches
+for i in $CWD/patches/* ; do patch -p1 -i $i ; done
-sed -i 's|CFLAGS="-Wall -Werror "|CFLAGS="${CFLAGS:--Wall -Werror}"|' configure.ac configure
+autoreconf -fi
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \