summaryrefslogtreecommitdiffstats
path: root/system/fsviewer/fsviewer.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/fsviewer/fsviewer.SlackBuild')
-rw-r--r--system/fsviewer/fsviewer.SlackBuild112
1 files changed, 62 insertions, 50 deletions
diff --git a/system/fsviewer/fsviewer.SlackBuild b/system/fsviewer/fsviewer.SlackBuild
index 0f245f4335..d713c6e59f 100644
--- a/system/fsviewer/fsviewer.SlackBuild
+++ b/system/fsviewer/fsviewer.SlackBuild
@@ -1,15 +1,26 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for fsviewer
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20240122 bkw: switch to roblillack's fork, v0.2.6+20220428_38b38a6.
+# Get rid of old patches (no longer needed), and add a new patch to
+# give the window a working close button.
+# 20230708 bkw: BUILD=3, install to the same Applications dir as
+# windowmaker's WPrefs.app (and no creating /usr/GNUstep, which was
+# never a good idea).
+# 20210825 bkw: fix build on -current, BUILD=2.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=fsviewer
-VERSION=${VERSION:-0.2.6}
+VERSION=${VERSION:-0.2.6+20220428_38b38a6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -19,7 +30,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -43,49 +58,46 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-app-$VERSION
-tar xvf $CWD/$PRGNAM-app-$VERSION.tar.bz2
-cd $PRGNAM-app-$VERSION
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
+cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# The WINGs API has changed slightly in the newer versions of WindowMaker
-patch -p1 < $CWD/wingsfix.diff
-
-# See README.patch.txt for info
-if [ "${TITLEBAR:-no}" = "yes" ]; then
- patch -p1 < $CWD/titlebar.diff
-fi
-
-LIBS="-lWUtil -lX11 -lm -lXpm" \
-CFLAGS="$SLKCFLAGS -std=gnu89" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --build=$ARCH-slackware-linux
-
-# fix broken gobbledegook emitted by autoconf. Life is too short
-# to spend time fixing it 'correctly'.
-GCCMAJVER=$( gcc --version | head -1 | cut -d' ' -f3 | cut -d. -f1 )
-[ "$GCCMAJVER" -ge 5 ] && sed -i 's,-MT *\$@,-M,' */Makefile */*/Makefile
-
-make
-make install-strip DESTDIR=$PKG
-
-mkdir -p $PKG/usr/bin
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +
+
+# 20240123 bkw: add a close button to the top-level window.
+patch -p1 < $CWD/close_button.diff
+
+# 20240122 bkw: install to /usr/lib(64), then mv the bin dir.
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr/lib$LIBDIRSUFFIX \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DMAN_INSTALL_DIR=/usr/man \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install/strip DESTDIR=$PKG
+cd ..
+
+mv $PKG/usr/lib*/bin $PKG/usr/bin
+
+# 20240123 bkw: symlink to the binary, same as the package name.
+ln -s FSViewer $PKG/usr/bin/$PRGNAM
+
+# 20240123 bkw: cmake doesn't build this, it was in the old package,
+# fortunately it's easy enough to include in the new one. I have no
+# idea what it's good for...
+sed -i '/config\.h/d' defs/chdef.c
+make -C defs chdef LDFLAGS="-lWINGs -lWUtil"
install -s -m0755 defs/chdef $PKG/usr/bin
-ln -s ../GNUstep/Apps/FSViewer.app/FSViewer $PKG/usr/bin/$PRGNAM
-gzip -9 $PKG/usr/man/man1/*
+mkdir -p $PKG/usr/man/man1
+for i in man/*.1x; do
+ gzip -9 < $i > $PKG/usr/man/man1/$( basename $i ).gz
+done
# .desktop file comes from the Polish Linux Distro, and has been modified
# to add the icon and to pass desktop-file-validate.
@@ -95,17 +107,17 @@ cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
# I like the look of FSViewer2.xpm better. You could use FSViewer.xpm if
# you prefer.
mkdir -p $PKG/usr/share/pixmaps
-ln -s ../../GNUstep/Apps/FSViewer.app/xpm/FSViewer2.xpm \
+ln -s ../../lib$LIBDIRSUFFIX/GNUstep/Apps/FSViewer.app/xpm/FSViewer2.xpm \
$PKG/usr/share/pixmaps/$PRGNAM.xpm
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING ChangeLog NEWS README docs/* \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC
+cp -a AUTHORS COPYING ChangeLog NEWS README* docs/* $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE