summaryrefslogtreecommitdiffstats
path: root/system/dump/dump.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/dump/dump.SlackBuild')
-rw-r--r--system/dump/dump.SlackBuild19
1 files changed, 6 insertions, 13 deletions
diff --git a/system/dump/dump.SlackBuild b/system/dump/dump.SlackBuild
index 046943a775..e414b78462 100644
--- a/system/dump/dump.SlackBuild
+++ b/system/dump/dump.SlackBuild
@@ -3,19 +3,17 @@
# Slackware build script for dump
# Written by Chris Abela <chris.abela@maltats.com>
-# July 2009
+# 30.07.2010
PRGNAM=dump
-VERSION=${VERSION:-0.4b42}
+VERSION=${VERSION:-0.4b43}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -54,7 +52,7 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# rmt is available on Slack's tar package, so I am disabling it.
+# rmt is available on Slack's tar package, so I am disabling it.
# The fully qualified mandir is necessary.
CFLAGS="$SLKCFLAGS" \
./configure \
@@ -70,24 +68,19 @@ CFLAGS="$SLKCFLAGS" \
--enable-rmt=no \
--enable-transselinux=no
-# This is needed as we do not have SELinux
-sed -i 's/ -lselinux -lsepol//' configure.in
-
make
make prefix=$PKG/usr install
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
-)
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $(find $PKG/usr/man -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
CHANGES COPYRIGHT INSTALL *BUGS MAINTAINERS README THANKS TODO examples \
- $PKG/usr/doc/$PRGNAM-$VERSION
+ $PKG/usr/doc/$PRGNAM-$VERSION
find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.Slackbuild