summaryrefslogtreecommitdiffstats
path: root/system/driconf
diff options
context:
space:
mode:
Diffstat (limited to 'system/driconf')
-rw-r--r--system/driconf/README7
-rw-r--r--system/driconf/doinst.sh3
-rw-r--r--system/driconf/driconf.SlackBuild29
-rw-r--r--system/driconf/driconf.info6
4 files changed, 30 insertions, 15 deletions
diff --git a/system/driconf/README b/system/driconf/README
index 5f87c5d991..5e7b2a4ab0 100644
--- a/system/driconf/README
+++ b/system/driconf/README
@@ -1,3 +1,4 @@
-DRIconf is a configuration applet for the Direct Rendering Infrastructure.
-It allows customizing performance and visual quality settings of OpenGL
-drivers on a per-driver, per-screen and/or per-application level.
+DRIconf is a configuration applet for the Direct Rendering
+Infrastructure. It allows customizing performance and visual
+quality settings of OpenGL drivers on a per-driver, per-screen and/or
+per-application level.
diff --git a/system/driconf/doinst.sh b/system/driconf/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/system/driconf/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/system/driconf/driconf.SlackBuild b/system/driconf/driconf.SlackBuild
index e3ccdcaf35..f2e0c03551 100644
--- a/system/driconf/driconf.SlackBuild
+++ b/system/driconf/driconf.SlackBuild
@@ -1,7 +1,7 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for driconf
-# Copyright 2011 David Woodfall <dave@dawoodfall.net>
+# Copyright 2011 David Woodfall <dave@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,10 +23,17 @@
# Thanks to James Powell for the .desktop file.
+# 20220410 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - install icon where the .desktop file expects to find it.
+# - add doinst.sh (need because we have a .desktop).
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=driconf
VERSION=${VERSION:-0.9.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,7 +43,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -66,9 +77,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ -exec chmod 644 {} \+
cat $CWD/driconf-0.9.1-2.diff | patch --verbose -p1
@@ -76,8 +87,7 @@ python setup.py install --root=$PKG
mkdir -p $PKG/usr/share/{applications,driconf}
cp $CWD/driconf.desktop $PKG/usr/share/applications/driconf.desktop
-cp -a driconf-icon.png $PKG/usr/share/applications/driconf-icon.png
-
+cp -a driconf-icon.png $PKG/usr/share/driconf/driconf-icon.png
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -88,6 +98,7 @@ cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/driconf/driconf.info b/system/driconf/driconf.info
index 8d99cd64be..19c4c03f59 100644
--- a/system/driconf/driconf.info
+++ b/system/driconf/driconf.info
@@ -1,10 +1,10 @@
PRGNAM="driconf"
VERSION="0.9.1"
HOMEPAGE="http://dri.freedesktop.org/wiki/DriConf"
-DOWNLOAD="http://unrealize.co.uk/source/driconf-0.9.1.tar.gz"
+DOWNLOAD="http://distcache.FreeBSD.org/ports-distfiles/driconf-0.9.1.tar.gz"
MD5SUM="76d610bcd56aa5e8a489debb5081178a"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="David Woodfall"
-EMAIL="dave@dawoodfall.net"
+MAINTAINER="D Woodfall"
+EMAIL="dave@slackbuilds.org"