summaryrefslogtreecommitdiffstats
path: root/system/driconf/driconf.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/driconf/driconf.SlackBuild')
-rw-r--r--system/driconf/driconf.SlackBuild27
1 files changed, 19 insertions, 8 deletions
diff --git a/system/driconf/driconf.SlackBuild b/system/driconf/driconf.SlackBuild
index 42f886f8d0..f2e0c03551 100644
--- a/system/driconf/driconf.SlackBuild
+++ b/system/driconf/driconf.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for driconf
# Copyright 2011 David Woodfall <dave@slackbuilds.org>
@@ -23,10 +23,17 @@
# Thanks to James Powell for the .desktop file.
+# 20220410 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - install icon where the .desktop file expects to find it.
+# - add doinst.sh (need because we have a .desktop).
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=driconf
VERSION=${VERSION:-0.9.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,7 +43,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -66,9 +77,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ -exec chmod 644 {} \+
cat $CWD/driconf-0.9.1-2.diff | patch --verbose -p1
@@ -76,8 +87,7 @@ python setup.py install --root=$PKG
mkdir -p $PKG/usr/share/{applications,driconf}
cp $CWD/driconf.desktop $PKG/usr/share/applications/driconf.desktop
-cp -a driconf-icon.png $PKG/usr/share/applications/driconf-icon.png
-
+cp -a driconf-icon.png $PKG/usr/share/driconf/driconf-icon.png
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -88,6 +98,7 @@ cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE