summaryrefslogtreecommitdiffstats
path: root/system/ded/ded.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/ded/ded.SlackBuild')
-rw-r--r--system/ded/ded.SlackBuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/system/ded/ded.SlackBuild b/system/ded/ded.SlackBuild
index fa67c0955b..ca200877e3 100644
--- a/system/ded/ded.SlackBuild
+++ b/system/ded/ded.SlackBuild
@@ -10,6 +10,8 @@
# This build script was written from scratch for 14.1, without referring
# to the old script.
+# 20210220 bkw: updated for 20210110. get rid of configure patch, found
+# a better way to disable the long filename test.
# 20200111 bkw: updated for 20200428 release
# 20200111 bkw: updated for 20191226 release
# 20180915 bkw: updated for 20180324 release
@@ -26,7 +28,7 @@
# - added td_lib docs in /usr/doc
PRGNAM=ded
-VERSION=${VERSION:-20200428}
+VERSION=${VERSION:-20210110}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -81,10 +83,13 @@ find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
# "checking for long filenames" wants to create files in /usr/lib and
# /var/lib. Violates the principle of least surprise: users don't expect
# configure scripts (or SlackBuilds) to touch their system directories.
-patch -p1 < $CWD/td_lib_no_write_usr.diff
-# NB: the -j1's are necessary, even on 'make install'.
+# This *should* work, but doesn't, I guess because configure.in is too old.
+#sed -i '/^AC_SYS_LONG_FILE_NAMES/d' configure.in
+#autoreconf -i
+# It turns out we can force it in the environment.
+ac_cv_sys_long_file_names="set" \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -95,6 +100,7 @@ CXXFLAGS="$SLKCFLAGS" \
--mandir=/usr/man \
--build=$ARCH-slackware-linux
+# NB: the -j1's are necessary, even on 'make install'.
make -j1
# actually, don't really need to make install, ded's configure will find