summaryrefslogtreecommitdiffstats
path: root/system/ddrescue-gui/ddrescue-gui.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/ddrescue-gui/ddrescue-gui.SlackBuild')
-rw-r--r--system/ddrescue-gui/ddrescue-gui.SlackBuild100
1 files changed, 0 insertions, 100 deletions
diff --git a/system/ddrescue-gui/ddrescue-gui.SlackBuild b/system/ddrescue-gui/ddrescue-gui.SlackBuild
deleted file mode 100644
index bb34d4e374..0000000000
--- a/system/ddrescue-gui/ddrescue-gui.SlackBuild
+++ /dev/null
@@ -1,100 +0,0 @@
-#!/bin/sh
-#
-# Slackware build script for ddrescue-gui.
-#
-# Copyright 2015-2019 Edinaldo P. Silva, Rio de Janeiro, Brazil.
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=ddrescue-gui
-VERSION=${VERSION:-2.0.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-SRCVER=${SRCVER:-2.0.2~otherdistro-0ubuntu1~ppa1}
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/${PRGNAM}_${SRCVER}.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-DATA="Tests Tools docs images other DDRescue_GUI.py tests.py"
-
-mkdir -p $PKG/usr/share/$PRGNAM
-cp -r $DATA $PKG/usr/share/$PRGNAM
-
-install -Dm644 org.hamishmb.ddrescue-gui.policy $PKG/usr/share/polkit-1/actions/org.hamishmb.ddrescue-gui.policy
-install -Dm644 $CWD/ddrescue-gui.desktop $PKG/usr/share/applications/ddrescue-gui.desktop
-install -Dm644 ddrescue-gui.png $PKG/usr/share/pixmaps/ddrescue-gui.png
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp debian/changelog $PKG/usr/doc/$PRGNAM-$VERSION/ChangeLog
-cp debian/copyright $PKG/usr/doc/$PRGNAM-$VERSION/copyright
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-install -Dm644 $CWD/ddrescue-gui.1 $PKG/usr/man/man1/ddrescue-gui.1
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}