summaryrefslogtreecommitdiffstats
path: root/system/dahdi-complete/dahdi-complete.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/dahdi-complete/dahdi-complete.SlackBuild')
-rw-r--r--system/dahdi-complete/dahdi-complete.SlackBuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/system/dahdi-complete/dahdi-complete.SlackBuild b/system/dahdi-complete/dahdi-complete.SlackBuild
index c6984aae30..bbfbde084c 100644
--- a/system/dahdi-complete/dahdi-complete.SlackBuild
+++ b/system/dahdi-complete/dahdi-complete.SlackBuild
@@ -10,7 +10,7 @@
# All rights reserved.
PRGNAM=dahdi-complete
-VERSION=${VERSION:-2.10.2}
+VERSION=${VERSION:-3.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -61,16 +61,19 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-sed -i -e 's/ -Werror//' tools/acinclude.m4 tools/xpp/Makefile
-sed -i -e 's/-Werror //' tools/Makefile
+sed -i -e 's/ -Werror//' tools/acinclude.m4 tools/xpp/Makefile.am
+sed -i -e 's/-Werror //' tools/Makefile.am
# Fix Perl install location (otherwise it installs to /usr/local/share/perl5)
-sed -i -e 's/sitelib/vendorlib/' linux/build_tools/live_dahdi tools/xpp/Makefile
+sed -i -e 's/sitelib/vendorlib/' linux/build_tools/live_dahdi tools/xpp/Makefile.am
cd linux
make all
cd ../tools
+./bootstrap.sh
+autoreconf -fi
+CPPFLAGS="-I$(pwd)/../linux/include" \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -88,6 +91,10 @@ make install DESTDIR=$PKG
cd ..
make config DESTDIR=$PKG
+mkdir -p $PKG/usr/share/perl5/vendor_perl
+mv $PKG/usr/local/share/perl5/* $PKG/usr/share/perl5/vendor_perl/
+rm -fR $PKG/usr/local
+
# move config files to .new
cd $PKG/etc
for file in $(find . -type f); do
@@ -103,7 +110,7 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
# Clean up zero-length firmware files
-find $PKG/lib/firmware -size 0 -delete
+find $PKG/lib/firmware -size 0 -delete || true
# Remove unused directory
rm -rf $PKG/usr/lib