summaryrefslogtreecommitdiffstats
path: root/system/conky
diff options
context:
space:
mode:
Diffstat (limited to 'system/conky')
-rw-r--r--system/conky/conky-1.10.6-gcc7.patch11
-rw-r--r--system/conky/conky.SlackBuild3
2 files changed, 14 insertions, 0 deletions
diff --git a/system/conky/conky-1.10.6-gcc7.patch b/system/conky/conky-1.10.6-gcc7.patch
new file mode 100644
index 0000000000..dcbc3bc8a5
--- /dev/null
+++ b/system/conky/conky-1.10.6-gcc7.patch
@@ -0,0 +1,11 @@
+diff -Naur conky-1.10.6.orig/src/luamm.hh conky-1.10.6/src/luamm.hh
+--- conky-1.10.6.orig/src/luamm.hh 2016-12-04 16:13:57.000000000 +0100
++++ conky-1.10.6/src/luamm.hh 2017-05-05 12:44:37.525676651 +0200
+@@ -27,6 +27,7 @@
+ #include <mutex>
+ #include <exception>
+ #include <stdexcept>
++#include <functional>
+ #include <string>
+
+ #include <lua.hpp>
diff --git a/system/conky/conky.SlackBuild b/system/conky/conky.SlackBuild
index c3f4948c36..395bcdce69 100644
--- a/system/conky/conky.SlackBuild
+++ b/system/conky/conky.SlackBuild
@@ -87,6 +87,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Fix for the newer gcc
+patch -p1 < $CWD/conky-1.10.6-gcc7.patch
+
# fix MANDIR
sed -i 's,share/man/man1,man/man1,g' CMakeLists.txt