summaryrefslogtreecommitdiffstats
path: root/system/bleachbit/patches
diff options
context:
space:
mode:
Diffstat (limited to 'system/bleachbit/patches')
-rw-r--r--system/bleachbit/patches/bleachbit-0.4.1-Unix.py.diff13
-rw-r--r--system/bleachbit/patches/bleachbit-0.4.1-launcher.diff27
2 files changed, 40 insertions, 0 deletions
diff --git a/system/bleachbit/patches/bleachbit-0.4.1-Unix.py.diff b/system/bleachbit/patches/bleachbit-0.4.1-Unix.py.diff
new file mode 100644
index 0000000000..e77e2ab025
--- /dev/null
+++ b/system/bleachbit/patches/bleachbit-0.4.1-Unix.py.diff
@@ -0,0 +1,13 @@
+--- trunk/bleachbit/Unix.py 2009/02/08 20:08:26 274
++++ trunk/bleachbit/Unix.py 2009/05/08 02:27:54 346
+@@ -447,7 +447,9 @@
+ regex = '-[0-9]{8}$'
+ globpaths = ( '/var/log/*-*', '/var/log/*/*-*' )
+ for path in FileUtilities.globex(globpaths, regex):
+- yield path
++ whitelist_re = '^/var/log/(removed_)?(packages|scripts)'
++ if None == re.match(whitelist_re, path): # for Slackware, Launchpad #367575
++ yield path
+
+
+ def wine_to_linux_path(wineprefix, windows_pathname):
diff --git a/system/bleachbit/patches/bleachbit-0.4.1-launcher.diff b/system/bleachbit/patches/bleachbit-0.4.1-launcher.diff
new file mode 100644
index 0000000000..8d10625e8a
--- /dev/null
+++ b/system/bleachbit/patches/bleachbit-0.4.1-launcher.diff
@@ -0,0 +1,27 @@
+Implement and install a launcher to start the GUI.
+
+Index: bleachbit-0.2.1/bin/bleachbit
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ bleachbit-0.2.1/bin/bleachbit 2009-01-29 22:10:20.641192983 +0100
+@@ -0,0 +1,8 @@
++#!/usr/bin/env python
++
++import bleachbit.GUI
++import gtk
++
++if __name__ == '__main__':
++ gui = bleachbit.GUI.GUI()
++ gtk.main()
+Index: bleachbit-0.2.1/setup.py
+===================================================================
+--- bleachbit-0.2.1.orig/setup.py 2009-01-29 22:10:13.625194708 +0100
++++ bleachbit-0.2.1/setup.py 2009-01-29 22:10:20.641192983 +0100
+@@ -25,6 +25,7 @@
+ data_files = []
+ data_files.append(('/usr/share/applications', ['./bleachbit.desktop']))
+ data_files.append(('/usr/share/pixmaps/', ['./bleachbit.png']))
++data_files.append(('/usr/bin', ['bin/bleachbit']))
+
+ setup(name='bleachbit',
+ version='0.4.1',