summaryrefslogtreecommitdiffstats
path: root/system/OpenSnitch/patches/fix-setup.py.patch
diff options
context:
space:
mode:
Diffstat (limited to 'system/OpenSnitch/patches/fix-setup.py.patch')
-rw-r--r--system/OpenSnitch/patches/fix-setup.py.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/system/OpenSnitch/patches/fix-setup.py.patch b/system/OpenSnitch/patches/fix-setup.py.patch
new file mode 100644
index 0000000000..c0ea3d94d5
--- /dev/null
+++ b/system/OpenSnitch/patches/fix-setup.py.patch
@@ -0,0 +1,21 @@
+This patch was taken from Arch Linux repositories:
+https://gitlab.archlinux.org/archlinux/packaging/packages/opensnitch/-/blob/main/fix-setup.py.patch
+--- a/ui/setup.py
++++ b/ui/setup.py
+@@ -28,11 +28,9 @@ These rules can last forever, until the app restart or just one time.',
+ packages=find_packages(),
+ include_package_data = True,
+ package_data={'': ['*.*']},
+- data_files=[('/usr/share/applications', ['resources/opensnitch_ui.desktop']),
+- ('/usr/share/kservices5', ['resources/kcm_opensnitch.desktop']),
+- ('/usr/share/icons/hicolor/scalable/apps', ['resources/icons/opensnitch-ui.svg']),
+- ('/usr/share/icons/hicolor/48x48/apps', ['resources/icons/48x48/opensnitch-ui.png']),
+- ('/usr/share/icons/hicolor/64x64/apps', ['resources/icons/64x64/opensnitch-ui.png']),
+- ('/usr/share/metainfo', ['resources/io.github.evilsocket.opensnitch.appdata.xml'])],
++ data_files=[('share/applications', ['resources/opensnitch_ui.desktop']),
++ ('share/kservices5', ['resources/kcm_opensnitch.desktop']),
++ ('share/icons/hicolor/scalable/apps', ['resources/icons/opensnitch-ui.svg']),
++ ('share/metainfo', ['resources/io.github.evilsocket.opensnitch.appdata.xml'])],
+ scripts = [ 'bin/opensnitch-ui' ],
+ zip_safe=False)
+