summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
Diffstat (limited to 'system')
-rw-r--r--system/audit/audit.SlackBuild5
-rw-r--r--system/conky/conky.SlackBuild2
-rw-r--r--system/heirloom-sh/heirloom-sh-glibc-2.34.patch18
-rw-r--r--system/heirloom-sh/heirloom-sh.SlackBuild2
-rw-r--r--system/osinfo-db-tools/osinfo-db-tools.SlackBuild4
-rw-r--r--system/osinfo-db-tools/osinfo-db-tools.info6
-rw-r--r--system/osinfo-db/osinfo-db.SlackBuild4
-rw-r--r--system/osinfo-db/osinfo-db.info6
-rw-r--r--system/qemu/README12
-rw-r--r--system/qemu/qemu.SlackBuild16
-rw-r--r--system/qemu/qemu.info8
-rw-r--r--system/uhd/uhd.SlackBuild9
-rw-r--r--system/vice/vice.SlackBuild1
-rw-r--r--system/vinterm/includes.diff10
-rw-r--r--system/vinterm/vinterm.SlackBuild4
-rw-r--r--system/virt-viewer/virt-viewer-10.0_p20210730-meson-0.61.patch36
-rw-r--r--system/virt-viewer/virt-viewer.SlackBuild2
-rw-r--r--system/virtiofsd/README19
-rw-r--r--system/virtiofsd/slack-desc19
-rw-r--r--system/virtiofsd/virtiofsd.SlackBuild104
-rw-r--r--system/virtiofsd/virtiofsd.info12
-rw-r--r--system/virtualbox-addons/gcc13.patch11
-rw-r--r--system/virtualbox-addons/virtualbox-addons.SlackBuild2
23 files changed, 282 insertions, 30 deletions
diff --git a/system/audit/audit.SlackBuild b/system/audit/audit.SlackBuild
index baf85c9b38..45aca7c2a1 100644
--- a/system/audit/audit.SlackBuild
+++ b/system/audit/audit.SlackBuild
@@ -79,6 +79,9 @@ find -L . \
# Init should check /etc/rc.d/rc.auditd.conf instead of /etc/sysconfig/auditd
patch -p1 < $CWD/audit-2.3.6-sysconfig.diff
+# python binding are disabled ATM, see
+# https://listman.redhat.com/archives/linux-audit/2022-February/msg00085.html
+# thanks to fourtysixandtwo for the pointers
CXXFLAGS="$SLKCFLAGS" \
CFLAGS="$SLKCFLAGS" \
./configure \
@@ -94,6 +97,8 @@ CFLAGS="$SLKCFLAGS" \
--enable-systemd=no \
--with-libcap-ng=yes \
--enable-gssapi-krb5=yes \
+ --without-python \
+ --without-python3 \
--build=$ARCH-slackware-linux
make
diff --git a/system/conky/conky.SlackBuild b/system/conky/conky.SlackBuild
index 2ce2abbbb1..50f9ba4614 100644
--- a/system/conky/conky.SlackBuild
+++ b/system/conky/conky.SlackBuild
@@ -102,7 +102,7 @@ cd build
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_SUFFIX=${LIBDIRSUFFIX} \
-DDOC_PATH=/usr/doc/$PRGNAM-$VERSION \
- -DMAINTAINER_MODE=ON \
+ -DMAINTAINER_MODE=OFF \
-DBUILD_DOCS=OFF \
-DBUILD_EXTRAS=ON \
-DBUILD_XDBE=ON \
diff --git a/system/heirloom-sh/heirloom-sh-glibc-2.34.patch b/system/heirloom-sh/heirloom-sh-glibc-2.34.patch
new file mode 100644
index 0000000000..35cb565526
--- /dev/null
+++ b/system/heirloom-sh/heirloom-sh-glibc-2.34.patch
@@ -0,0 +1,18 @@
+--- a/fault.c
++++ b/fault.c
+@@ -43,6 +43,15 @@
+ #include <errno.h>
+ #include <string.h>
+
++#if __GLIBC__ >= 2
++# undef SIGSTKSZ
++# if defined __ia64__
++# define SIGSTKSZ 262144
++# else
++# define SIGSTKSZ 65536
++# endif
++#endif
++
+ static void (*psig0_func)() = SIG_ERR; /* previous signal handler for signal 0 */
+ static char sigsegv_stack[SIGSTKSZ];
+
diff --git a/system/heirloom-sh/heirloom-sh.SlackBuild b/system/heirloom-sh/heirloom-sh.SlackBuild
index b805981e57..ce9edf218e 100644
--- a/system/heirloom-sh/heirloom-sh.SlackBuild
+++ b/system/heirloom-sh/heirloom-sh.SlackBuild
@@ -61,6 +61,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 \
-o -perm 400 \) -exec chmod 644 {} \;
+patch -p1 < $CWD/heirloom-sh-glibc-2.34.patch
+
# configure is the worst way to build a package except for all the others
# 1. make static changes to the makefile with a patch
patch -p1 < $CWD/makefile.patch
diff --git a/system/osinfo-db-tools/osinfo-db-tools.SlackBuild b/system/osinfo-db-tools/osinfo-db-tools.SlackBuild
index c689e31156..bfc9df1476 100644
--- a/system/osinfo-db-tools/osinfo-db-tools.SlackBuild
+++ b/system/osinfo-db-tools/osinfo-db-tools.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for osinfo-db-tools
-# Copyright 2016-2023 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
+# Copyright 2016-2024 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=osinfo-db-tools
-VERSION=${VERSION:-1.10.0}
+VERSION=${VERSION:-1.11.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
diff --git a/system/osinfo-db-tools/osinfo-db-tools.info b/system/osinfo-db-tools/osinfo-db-tools.info
index ad699ecdc1..99dae01bac 100644
--- a/system/osinfo-db-tools/osinfo-db-tools.info
+++ b/system/osinfo-db-tools/osinfo-db-tools.info
@@ -1,8 +1,8 @@
PRGNAM="osinfo-db-tools"
-VERSION="1.10.0"
+VERSION="1.11.0"
HOMEPAGE="http://libosinfo.org"
-DOWNLOAD="https://releases.pagure.org/libosinfo/osinfo-db-tools-1.10.0.tar.xz"
-MD5SUM="f0c83772ce612b5d0befb77a8d6f309b"
+DOWNLOAD="https://releases.pagure.org/libosinfo/osinfo-db-tools-1.11.0.tar.xz"
+MD5SUM="8fed1cfc692b6fa1a80f002b0a8447ac"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/system/osinfo-db/osinfo-db.SlackBuild b/system/osinfo-db/osinfo-db.SlackBuild
index f1d803ad2f..36b70adec7 100644
--- a/system/osinfo-db/osinfo-db.SlackBuild
+++ b/system/osinfo-db/osinfo-db.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for osinfo-db
-# Copyright 2016-2023 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
+# Copyright 2016-2024 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=osinfo-db
-VERSION=${VERSION:-20230308}
+VERSION=${VERSION:-20231215}
SLVERSION=${SLVERSION:-20220214}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
diff --git a/system/osinfo-db/osinfo-db.info b/system/osinfo-db/osinfo-db.info
index c61d3a665e..4ce4d8ae5b 100644
--- a/system/osinfo-db/osinfo-db.info
+++ b/system/osinfo-db/osinfo-db.info
@@ -1,9 +1,9 @@
PRGNAM="osinfo-db"
-VERSION="20230308"
+VERSION="20231215"
HOMEPAGE="http://libosinfo.org"
-DOWNLOAD="https://releases.pagure.org/libosinfo/osinfo-db-20230308.tar.xz \
+DOWNLOAD="https://releases.pagure.org/libosinfo/osinfo-db-20231215.tar.xz \
https://harrier.slackbuilds.org/misc/osinfo-db-slackware-20220214.tar.xz"
-MD5SUM="0293bded4e2b7b22fe87bd629d2b71ce \
+MD5SUM="45021bc702e722d1f5dd062f4823d160 \
65ed4d991bdab6ab00bc34bcbb5d16ff"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
diff --git a/system/qemu/README b/system/qemu/README
index 1c9b196e0c..82e16158ad 100644
--- a/system/qemu/README
+++ b/system/qemu/README
@@ -41,14 +41,12 @@ your processor) prior to launching qemu-system-ARCH with kvm enabled.
For older/unmaintained qemu frontends, this build also creates a symlink
to qemu-system-ARCH at /usr/bin/qemu-kvm.
-libslirp (user mode networking), libcacard, spice, usbredir,
-virglrenderer, libnfs, snappy, device-tree-compiler, glusterfs, and vde2
-are optional dependencies.
+libcacard, spice, usbredir, virglrenderer, libnfs, snappy, glusterfs,
+device-tree-compiler, and vde2 are optional dependencies.
-To enable user mode networking, install libslirp (availale on SBO), then
-compile qemu:
+To disable user mode networking compile qemu with:
-SLIRP=yes ./qemu.SlackBuild
+ SLIRP=no ./qemu.SlackBuild
libiscsi (to access iSCSI targets directly) is optional dependency,
and will be picked up, if present, during the compilation.
@@ -58,6 +56,8 @@ order for any of the documentation to be built.
If you wish to emulate ARM, you will want device-tree-compiler.
+The dependency virtiofsd isn't usable on a 32bit operating system.
+
NOTES:
This version breaks some backward compatibility with earlier versions.
Consult the official changelogs for details.
diff --git a/system/qemu/qemu.SlackBuild b/system/qemu/qemu.SlackBuild
index b3f726443b..53c57e8d25 100644
--- a/system/qemu/qemu.SlackBuild
+++ b/system/qemu/qemu.SlackBuild
@@ -32,8 +32,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=qemu
-VERSION=${VERSION:-7.2.1}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-8.2.2}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -117,13 +117,13 @@ else
with_vnc="--disable-vnc"
fi
-# To enable user mode networking use SLIRP=yes
-if [ "$SLIRP" = "yes" ]; then
- with_slirp="--enable-slirp"
+# To disable user mode networking use SLIRP=no
+if [ "$SLIRP" = "no" ]; then
+ with_slirp="--disable-slirp"
else
- with_slirp=""
+ with_slirp="--enable-slirp"
fi
-
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -138,10 +138,10 @@ CXXFLAGS="$SLKCFLAGS" \
--disable-debug-info \
--enable-virtfs \
--enable-sdl \
- --enable-jemalloc \
--enable-nettle \
--${uring}able-linux-io-uring \
--audio-drv-list=${AUDIODRIVERS} \
+ --disable-xkbcommon \
$with_slirp \
$with_vnc \
$targets
diff --git a/system/qemu/qemu.info b/system/qemu/qemu.info
index cab62c9ead..805c585dc8 100644
--- a/system/qemu/qemu.info
+++ b/system/qemu/qemu.info
@@ -1,10 +1,10 @@
PRGNAM="qemu"
-VERSION="7.2.1"
+VERSION="8.2.2"
HOMEPAGE="https://www.qemu.org"
-DOWNLOAD="https://download.qemu.org/qemu-7.2.1.tar.xz"
-MD5SUM="48ec3eadc151f0eceb641c0c7a13374c"
+DOWNLOAD="https://download.qemu.org/qemu-8.2.2.tar.xz"
+MD5SUM="e43091262671c1728b09522932b75b1d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="libslirp virtiofsd"
MAINTAINER="Edward W. Koenig"
EMAIL="kingbeowulf@linuxgalaxy.org"
diff --git a/system/uhd/uhd.SlackBuild b/system/uhd/uhd.SlackBuild
index 54aa0051ed..5e8171fa21 100644
--- a/system/uhd/uhd.SlackBuild
+++ b/system/uhd/uhd.SlackBuild
@@ -85,6 +85,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+# fix building with gcc >= 13.x
+sed -i s/\#include\ \<stddef.h\>/\#include\ \<stddef.h\>\\n\#include\ \<cstdint\>/ ./include/uhd/cal/database.hpp
+sed -i s/\#include\ \<string\>/\#include\ \<string\>\\n\#include\ \<cstdint\>/ ./include/uhd/rfnoc/defaults.hpp
+sed -i s/\#include\ \<cstddef\>/\#include\ \<cstddef\>\\n\#include\ \<cstdint\>/ ./lib/usrp/dboard/magnesium/magnesium_constants.hpp
+sed -i s/\#include\ \<cstddef\>/\#include\ \<cstddef\>\\n\#include\ \<cstdint\>/ ./lib/usrp/dboard/rhodium/rhodium_constants.hpp
+sed -i s/\#include\ \<string\>/\#include\ \<string\>\\n\#include\ \<cstdint\>/ ./include/uhd/types/eeprom.hpp
+sed -i s/\#include\ \<string\>/\#include\ \<string\>\\n\#include\ \<cstdint\>/ ./lib/include/uhdlib/utils/serial_number.hpp
+sed -i s/\#include\ "cast.h"/\#include\ "cast.h"\\n\#include\ \<cstdint\>/ ./lib/deps/pybind11/include/pybind11/attr.h
+
mkdir -p build
cd build
cmake \
diff --git a/system/vice/vice.SlackBuild b/system/vice/vice.SlackBuild
index 38aa08d8c5..e67c0fd235 100644
--- a/system/vice/vice.SlackBuild
+++ b/system/vice/vice.SlackBuild
@@ -104,6 +104,7 @@ set -e
# ffmpeg is included in the base OS on post-14.2 -current, but leave
# this here in case someone's doing something clever.
[ -x /usr/bin/ffmpeg ] && ffmpeg="--enable-ffmpeg"
+ffmpeg="" # ...but with ffmpeg 5.x is broken ATM
# Anticipating 15.0's pure-alsa-system
# 20240214 bkw: which sadly never materialized. I keep this here for
diff --git a/system/vinterm/includes.diff b/system/vinterm/includes.diff
new file mode 100644
index 0000000000..28b9096c59
--- /dev/null
+++ b/system/vinterm/includes.diff
@@ -0,0 +1,10 @@
+--- vinterm-0.5.0/terminal/pty.h 2013-08-20 01:34:06.000000000 +0900
++++ vinterm-0.5.0.patched/terminal/pty.h 2023-07-01 09:41:53.057899502 +0900
+@@ -3,6 +3,7 @@
+
+ #include <string>
+ #include <ostream>
++#include <cstdint>
+ using namespace std;
+
+ class Options;
diff --git a/system/vinterm/vinterm.SlackBuild b/system/vinterm/vinterm.SlackBuild
index 05afe5718c..5d88b5236d 100644
--- a/system/vinterm/vinterm.SlackBuild
+++ b/system/vinterm/vinterm.SlackBuild
@@ -15,7 +15,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=vinterm
VERSION=${VERSION:-0.5.0}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -66,6 +66,8 @@ sed -i -e "s,-Os,$SLKCFLAGS," -e "s,usr/lib,usr/lib$LIBDIRSUFFIX," config.mk
# GRR. "make install" respects DESTDIR... except for the icons and .desktop.
patch -p1 < $CWD/fix_destdir.diff
+# Add an include statement for GCC compatibility.
+patch -p1 < $CWD/includes.diff
export TERMINFO=$PKG/usr/share/terminfo
mkdir -p $TERMINFO
diff --git a/system/virt-viewer/virt-viewer-10.0_p20210730-meson-0.61.patch b/system/virt-viewer/virt-viewer-10.0_p20210730-meson-0.61.patch
new file mode 100644
index 0000000000..46c708b9d3
--- /dev/null
+++ b/system/virt-viewer/virt-viewer-10.0_p20210730-meson-0.61.patch
@@ -0,0 +1,36 @@
+https://gitlab.com/virt-viewer/virt-viewer/-/merge_requests/117.patch
+https://bugs.gentoo.org/831963
+
+From 41cc016278e713d3db156761fce6437dff81a53a Mon Sep 17 00:00:00 2001
+From: Michal Vasilek <michal@vasilek.cz>
+Date: Sat, 22 Jan 2022 23:28:20 +0100
+Subject: [PATCH] meson: fix build with meson 0.61
+
+i18n.merge_file doesn't accept positional arguments
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -2,7 +2,6 @@ if host_machine.system() != 'windows'
+ desktop = 'remote-viewer.desktop'
+
+ i18n.merge_file (
+- desktop,
+ type: 'desktop',
+ input: desktop + '.in',
+ output: desktop,
+@@ -14,7 +13,6 @@ if host_machine.system() != 'windows'
+ mimetypes = 'virt-viewer-mime.xml'
+
+ i18n.merge_file (
+- mimetypes,
+ type: 'xml',
+ input: mimetypes + '.in',
+ output: mimetypes,
+@@ -27,7 +25,6 @@ if host_machine.system() != 'windows'
+ metainfo = 'remote-viewer.appdata.xml'
+
+ i18n.merge_file (
+- metainfo,
+ type: 'xml',
+ input: metainfo + '.in',
+ output: metainfo,
+GitLab
diff --git a/system/virt-viewer/virt-viewer.SlackBuild b/system/virt-viewer/virt-viewer.SlackBuild
index c0601c673f..01d6ef5068 100644
--- a/system/virt-viewer/virt-viewer.SlackBuild
+++ b/system/virt-viewer/virt-viewer.SlackBuild
@@ -68,6 +68,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+patch -p1 < $CWD/virt-viewer-10.0_p20210730-meson-0.61.patch
+
mkdir build
cd build
CFLAGS="$SLKCFLAGS" \
diff --git a/system/virtiofsd/README b/system/virtiofsd/README
new file mode 100644
index 0000000000..45d12f2526
--- /dev/null
+++ b/system/virtiofsd/README
@@ -0,0 +1,19 @@
+virtiofsd is a vhost-user virtio-fs device backend written in Rust.
+
+This won't work on a 32bit operating system.
+
+NOTE: if you wish to update virtiofsd yourself you need to create a
+tarball first with the vendored versions of the rust dependencies:
+to create the "vendor" source dir yourself unpack the virtiofsd
+tarball, enter its directory and execute these three commands
+
+ export LD_LIBRARY_PATH="/opt/rust16/lib64:$LD_LIBRARY_PATH"
+ export PATH="/opt/rust16/bin:$PATH"
+ cargo vendor
+
+then you can create a tarball with
+
+ tar Jcf ../virtiofsd-vendor-$VERSION.tar.xz vendor
+
+this is necessary to avoid downloading stuff during execution of
+the SlackBuild.
diff --git a/system/virtiofsd/slack-desc b/system/virtiofsd/slack-desc
new file mode 100644
index 0000000000..a1e87c22f0
--- /dev/null
+++ b/system/virtiofsd/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+virtiofsd: virtiofsd (vhost-user virtio-fs device backend)
+virtiofsd:
+virtiofsd: virtiofsd is a vhost-user virtio-fs device backend written in Rust.
+virtiofsd:
+virtiofsd: homepage: https://virtio-fs.gitlab.io
+virtiofsd:
+virtiofsd:
+virtiofsd:
+virtiofsd:
+virtiofsd:
+virtiofsd:
diff --git a/system/virtiofsd/virtiofsd.SlackBuild b/system/virtiofsd/virtiofsd.SlackBuild
new file mode 100644
index 0000000000..fa42211bc3
--- /dev/null
+++ b/system/virtiofsd/virtiofsd.SlackBuild
@@ -0,0 +1,104 @@
+#!/bin/bash
+
+# Slackware build script for virtiofsd
+
+# Copyright 2023-2024 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=virtiofsd
+VERSION=${VERSION:-1.10.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ x86_64) ARCH=x86_64 ;;
+# arm*) ARCH=arm ;;
+ *) echo "ARCH $(uname -m) is unsupported."; exit 1 ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ LIBDIRSUFFIX="64"
+else
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-v$VERSION
+tar xvf $CWD/$PRGNAM-v$VERSION.tar.?z*
+cd $PRGNAM-v$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION-vendor.tar.xz
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+export PATH="/opt/rust16/bin:$PATH"
+if [ -z "$LD_LIBRARY_PATH" ]; then
+ export LD_LIBRARY_PATH="/opt/rust16/lib$LIBDIRSUFFIX"
+else
+ export LD_LIBRARY_PATH="/opt/rust16/lib$LIBDIRSUFFIX:$LD_LIBRARY_PATH"
+fi
+
+mkdir .cargo
+cat <<EOT >>.cargo/config.toml
+[source.crates-io]
+replace-with = "vendored-sources"
+
+[source.vendored-sources]
+directory = "vendor"
+EOT
+
+cargo build --release
+install -D -p -s -m 0755 target/release/$PRGNAM $PKG/usr/libexec/$PRGNAM
+install -D -p -m 0644 50-virtiofsd.json $PKG/usr/share/qemu/vhost-user/50-virtiofsd.json
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.md doc/*.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/virtiofsd/virtiofsd.info b/system/virtiofsd/virtiofsd.info
new file mode 100644
index 0000000000..4f10e98319
--- /dev/null
+++ b/system/virtiofsd/virtiofsd.info
@@ -0,0 +1,12 @@
+PRGNAM="virtiofsd"
+VERSION="1.10.1"
+HOMEPAGE="https://virtio-fs.gitlab.io"
+DOWNLOAD="UNSUPPORTED"
+MD5SUM=""
+DOWNLOAD_x86_64="https://gitlab.com/virtio-fs/virtiofsd/-/archive/v1.10.1/virtiofsd-v1.10.1.tar.bz2 \
+ https://ponce.cc/slackware/sources/repo/virtiofsd-1.10.1-vendor.tar.xz"
+MD5SUM_x86_64="c6fd3f5b7a83c908f9e08127ec92edc6 \
+ d4538be9ccd5f48561e9dc5d98981eb6"
+REQUIRES="rust16"
+MAINTAINER="Matteo Bernardini"
+EMAIL="ponce@slackbuilds.org"
diff --git a/system/virtualbox-addons/gcc13.patch b/system/virtualbox-addons/gcc13.patch
new file mode 100644
index 0000000000..40701d717f
--- /dev/null
+++ b/system/virtualbox-addons/gcc13.patch
@@ -0,0 +1,11 @@
+--- Config.kmk.orig 2023-04-13 03:15:13.000000000 -0600
++++ Config.kmk 2023-06-16 09:59:19.820597642 -0600
+@@ -7485,7 +7485,7 @@
+ TEMPLATE_VBOXGUESTR3XF86MOD_LDFLAGS.amd64 = -m elf_x86_64
+ endif
+ TEMPLATE_VBOXGUESTR3XF86MOD_CFLAGS = $(TEMPLATE_VBOXGUESTR3EXE_CFLAGS) -fno-pie -fno-merge-constants -std=c99 -ffreestanding
+-TEMPLATE_VBOXGUESTR3XF86MOD_CXXFLAGS= $(TEMPLATE_VBOXGUESTR3EXE_CXXFLAGS) -fno-pie -fno-merge-constants -ffreestanding
++TEMPLATE_VBOXGUESTR3XF86MOD_CXXFLAGS= $(TEMPLATE_VBOXGUESTR3EXE_CXXFLAGS) -fno-pie -fno-merge-constants
+ TEMPLATE_VBOXGUESTR3XF86MOD_CFLAGS.linux = $(VBOX_GCC_fno-stack-protector) # Remove symvers.h
+ TEMPLATE_VBOXGUESTR3XF86MOD_CXXFLAGS.linux = $(VBOX_GCC_fno-stack-protector) # Remove symvers.h
+ TEMPLATE_VBOXGUESTR3XF86MOD_SYSSUFF = .o
diff --git a/system/virtualbox-addons/virtualbox-addons.SlackBuild b/system/virtualbox-addons/virtualbox-addons.SlackBuild
index 2f24d766d5..14b11d6e33 100644
--- a/system/virtualbox-addons/virtualbox-addons.SlackBuild
+++ b/system/virtualbox-addons/virtualbox-addons.SlackBuild
@@ -89,6 +89,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+patch -p0 < $CWD/gcc13.patch
+
./configure \
--only-additions \
--disable-kmods \