summaryrefslogtreecommitdiffstats
path: root/python/traittypes/traittypes.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/traittypes/traittypes.SlackBuild')
-rw-r--r--python/traittypes/traittypes.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/python/traittypes/traittypes.SlackBuild b/python/traittypes/traittypes.SlackBuild
index e36132ba87..e0354fef21 100644
--- a/python/traittypes/traittypes.SlackBuild
+++ b/python/traittypes/traittypes.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for traittypes
-# Copyright 2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2018-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=traittypes
VERSION=${VERSION:-0.2.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,7 +69,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true