summaryrefslogtreecommitdiffstats
path: root/python/traitlets
diff options
context:
space:
mode:
Diffstat (limited to 'python/traitlets')
-rw-r--r--python/traitlets/traitlets.SlackBuild49
-rw-r--r--python/traitlets/traitlets.info12
2 files changed, 12 insertions, 49 deletions
diff --git a/python/traitlets/traitlets.SlackBuild b/python/traitlets/traitlets.SlackBuild
index 9aae07430d..341bd19859 100644
--- a/python/traitlets/traitlets.SlackBuild
+++ b/python/traitlets/traitlets.SlackBuild
@@ -3,7 +3,8 @@
# Slackware build script for traitlets
# Copyright 2017-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2022-2023 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2023-2024 Jeremy Hansen <jebrhansen+SBo@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=traitlets
-VERSION=${VERSION:-5.3.0}
+VERSION=${VERSION:-5.14.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -51,20 +49,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -80,36 +64,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Use this setup.py shim:
-cat << EOF > setup.py
-from distutils.core import setup
-import os
-here = os.path.abspath(os.path.dirname(__file__))
-pjoin = os.path.join
-packages = []
-for d, _, _ in os.walk(pjoin(here, 'traitlets')):
- if os.path.exists(pjoin(d, '__init__.py')):
- packages.append(d[len(here)+1:].replace(os.path.sep, '.'))
-version_ns = {}
-with open(pjoin(here, 'traitlets', '_version.py')) as f:
- exec(f.read(), {}, version_ns)
-setup(name='${PRGNAM}',
- version=version_ns['__version__'],
- packages=packages,
- package_data={'': ['*']},
-)
-EOF
-
-# With the shim, it's a good idea to use "unshare -n" to prevent downloading
-# anything extra:
-unshare -n python3 setup.py install --root=$PKG || exit 1
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- CHANGES.txt CONTRIBUTING.md COPYING.md README.md \
+ CHANGES.txt CONTRIBUTING.md README.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/python/traitlets/traitlets.info b/python/traitlets/traitlets.info
index e79946f7d5..60f0fc417f 100644
--- a/python/traitlets/traitlets.info
+++ b/python/traitlets/traitlets.info
@@ -1,10 +1,10 @@
PRGNAM="traitlets"
-VERSION="5.3.0"
+VERSION="5.14.3"
HOMEPAGE="https://jupyter.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/t/traitlets/traitlets-5.3.0.tar.gz"
-MD5SUM="ea9b920bd09fa8fcc44325c4d6a6800d"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/t/traitlets/traitlets-5.14.3.tar.gz"
+MD5SUM="f6e6529cca4cbe3299e3f07ce24d3fdc"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="decorator"
-MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.com"
+REQUIRES="python3-hatchling"
+MAINTAINER="Jeremy Hansen"
+EMAIL="jebrhansen+SBo@gmail.com"