summaryrefslogtreecommitdiffstats
path: root/python/sqlalchemy-migrate/sqlalchemy-migrate.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/sqlalchemy-migrate/sqlalchemy-migrate.SlackBuild')
-rw-r--r--python/sqlalchemy-migrate/sqlalchemy-migrate.SlackBuild31
1 files changed, 19 insertions, 12 deletions
diff --git a/python/sqlalchemy-migrate/sqlalchemy-migrate.SlackBuild b/python/sqlalchemy-migrate/sqlalchemy-migrate.SlackBuild
index 7225f33d0b..a2977d45dd 100644
--- a/python/sqlalchemy-migrate/sqlalchemy-migrate.SlackBuild
+++ b/python/sqlalchemy-migrate/sqlalchemy-migrate.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for SQLAlchemy-migrate
-# Copyright 2014-2019 Kyle Guinn <elyk03@gmail.com>
+# Copyright 2014-2021 Kyle Guinn <elyk03@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=sqlalchemy-migrate
-VERSION=${VERSION:-0.12.0}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-0.13.0}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$(uname -m)" in
@@ -35,9 +38,16 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM-$VERSION
+PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
DOCS="AUTHORS COPYING ChangeLog README.rst TODO"
@@ -53,12 +63,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go-w,a+rX-st .
-# Prefer python2 executables in /usr/bin for now by installing them last.
-if python3 -c 'import sys' 2>/dev/null; then
- python3 ./setup.py install --root=$PKG
- rm -rf build
-fi
python2 setup.py install --root=$PKG
+rm -rf build
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
@@ -68,4 +75,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE