summaryrefslogtreecommitdiffstats
path: root/python/six/six.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/six/six.SlackBuild')
-rw-r--r--python/six/six.SlackBuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/python/six/six.SlackBuild b/python/six/six.SlackBuild
index 69506ba6cc..f4f61c16ca 100644
--- a/python/six/six.SlackBuild
+++ b/python/six/six.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for six
-# Copyright 2012-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2017 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=six
-VERSION=${VERSION:-1.10.0}
+VERSION=${VERSION:-1.11.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -57,10 +57,6 @@ find -L . \
python setup.py install --root=$PKG
-if [ "${PYTHON3:-no}" == "yes" ]; then
- python3 setup.py install --root=$PKG
-fi
-
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -72,7 +68,7 @@ if $(python -c 'import sphinx.pygments_styles' 2>/dev/null); then
fi
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
[ -d documentation/_build/singlehtml ] && \
cp -a documentation/_build/singlehtml/index.html \
documentation/_build/singlehtml/_static \